Download assistant won't login SOLVED

OK, so as one cannot install or authorise the software without first downloading it, one would think that the Download Assistant would be smart enough to tell me that its brother, Activation Manager, was not up to date. So having figured this out by reading on Steinberg’s website that the download assistant will not work if the other packages are not up to date…well it’s probably just my brain that thinks this shouldn’t be so frustratingly opaque…

I just bought D5 upgrade - tried to install, but Download assistant tells me it cannot access the server, try my internet connection etc.
Internet is working fine (here I am)
Download download assistant and re-installed.
Same problem.
Will download D5 directly and hope I can authorise…
Any suggestions for Download Assistance’s refusal to assist me (it has one job…)
Thanks!
Simon

I’m sorry you had problems sorting out the downloads. If you hadn’t downloaded anything in a while, it’s possible that you still had a version of Steinberg Download Assistant older than version 1.35 installed on your computer, and due to a problem with a certificate having expired, you might have ended up in a situation where SDA can no longer securely contact the server and hence cannot update itself. If that was in fact the case, to solve it, you should manually download the latest version of SDA, install it, and it will then be able to connect to the servers and update everything else.

thanks @dspreadbury - yes the SDA was out of date.
Apologies for my tetchy post - I have a very short fuse when things don’t work as I expect them to…just be thankful you’re not the support guys at Softube this week :joy: :innocent: :sunglasses: