Download path problem with Download Assistant

Hi All

I’m not a big user of Cubase as I don’t seem to get the time to spend on it! I don’t use any other DAWs.

However, I am having a few problems with some things which I would really appreciate some help with. I will post the problems I’m having separately starting with this one.

I started my Cubase journey with Cubase 10.5, through 11 and now 12PRO.
I must have had to update previous iterations and have no log of any issues (I log things I do for my future use) when doing so.

On the Steinberg Download Assistant, I have the following (screenshot):

When clicking on “Install” to install Version 12.0.70, I get the following error message (screenshot):

I presume that Cubase installs itself in a default directory on the C drive, and I have never changed where it is situated.
Right clicking on the Cubase shortcut on my desktop, I can see that the file paths shown are:

Start In: C:\Program Files\Steinberg\Cubase 12
Target: C:\Program Files\Steinberg\Cubase 12\Cubase 12.exe

I have also clicked on “Security” in the Cubase Properties (R click on the Cubase shortcut again) and this shows (amongst other headings) that under"Administrator Desktop" Full Control is checked. I have administrator rights set up for me on the desktop PC.
It also shows that under the heading of "my name (me@bt…com) I am set up only with “Special Permissions”. I have edited this to show as “Full Control” in case the update process reads from this.

After saving these, I tried again to update to 12.0.70 but with the same results as previously.

Also, if I click on install on any of the other items with that option as per the first screenshot above, I get the same error message.

Does anyone have any idea why I can’t update please ?

Thankyou. :thinking:

Somehow the target folder was switched to place that cannot be used. The Windows Program Directory is not User writeable.

You should simply use the default folder.

Hit the Settings gear and then Reset to default.

1 Like

Hi Steve

Wow !!
What a quick response. Much appreciated.

Did as you said.
The file path changed (I think), but still got the same error message.

Let me know when you are sure.

1 Like

Hi Steve

On the item on this screenshot, I wasn’t particularly looking at the highlighted bit, but I thought I saw it change.

But, R clicking on ther Cubase shortcut after clicking on the “Reset to Default” button, it shows the same Target and Start Locations and the target folder (just above the Cubase 12.0.70 Application (required) on screenshot 1) still shows as it did then, so I gues overall, it didn’t actually change the default folder.

Try quitting and restarting the Download assistant.

Here’s how it should work. Maybe a Computer restart is needed?

Have you customized file paths in your Windows User environment?
Is your Download folder actually at image?


1 Like

Will close everything and start again.
Will let you know what happens.
Thanks again.

Alternatively, you can start the Download Assistant as Administrator.

If you want to move the download directory, make sure the new directory is not under a system directory.
This would lead to the same restrictions as before.

1 Like

Hi Steve

SUCCESS !! :sunglasses:

Ran Download Assistant as administrator and it updated with no problem.
I assume that the other items will now be able to be installed.

Thank you so much for your excellent comms. :smiling_face_with_three_hearts:

Do I need to tag this as solved ?

Sorry, think I’ve just found out how to flag as solved.

Thanks again !!

Appologies. just noticed you are a different poster to Steve.

Thank you too for your help.