DownloadCubase 11 via Assistant

I have been attempting to download Cubase 11 via the Steinberg Download Assistant, but keep recieving the error: “A connection to the download server could not be established. Check your internet connection and try again.”

I have switched my internext connection twice, to a different router in the house each time, and I have reinstalled the Steinberg Download Assistant only to see the same message as the one above. Does anyone know how to solve t

Steinberg’s server is probably overloaded. Maybe wait until Monday and try again.

1 Like

I still have the same error. Did it work for you in the mean time @JackMonaghan?

No it did not. In fact, I’m still talking with Steinberg’s support team today about this very issue.

1 Like

I just bought the Cubase 12 upgrade from 11 and installed the emailed download assistant and I’m getting this same error on my Mac. I’ve always been able to connect to Steinberg and pull downloads on this computer. Nothing has changed on my end. I have uninstalled and reinstalled the downloaded assistant, I have reboot, turned network connectivity on and off, verified firewall settings. Actually the firewall is off. No Luck.

I just want to provide an update to my comment on this thread, I was able to get passed the error. I didn’t make any changes. All I did was power down my Mac, powered back up an hour later and launched the download assistant. I was redirected to the Steinberg Authorize Downloads page where I was prompted to sign in with my Steinberg credentials. The download assistant app was then granted the access to proceed with pulling my account information down from Steinberg. Hope this helps someone.

I am also having this problem.

I have tried two locations. It worked in January when I updated Dorico but not it doesn’t work at all.

I deleted Dorico so I could move it to my secondary hard drive and not I have been without Dorico for nearly two weeks. I need this to work.

Same issue here in Nov 2023 so I downloaded the latest SDA and it worked ok, allowing me access.

1 Like

Same issue here, November 2023, even with version 1.35.
But, it is weird that FIRST TIME after installation (launched “inside” installation) have successfully start. After that, any try is unsuccessful, with message “A connection to the download server could not be established”.

1 Like

Now in Nov 25 2023, I am also affected to this issue.

I hope it is only temporary a hiccup…

I updated it to version 135 and now it works fine. Now I am a Dorico 5 user :slight_smile:

Having the same problem since 4 days!!
Steinberg Server seems to go down everytime they release a new version! :frowning:

1 Like

Did you download the latest Download Assistant release outside of the SDA?

1 Like

This solved the issue for me too!

Yes, of course.
I am talking about problems with LATEST (1.35) version!!!

To summarize, we’re all finding that booting up the download assistant causes the “Connection could not be established.” dialog box to appear, with the consequent quitting out of download assistant. When this happens, you have to download the latest version of the download assistant and install it.

Download Assistant apparently does not have a version check function on app start-up. The engineers may have opted to band-aid the situation for now by just shutting down. Perhaps this will be managed in the future one of several ways, the least sophisticated of which might be to do a version check on app start-up, then put up a dialog box that says, “Steinberg Download Assistant needs to be updated. Please go to this link to download the latest version first.” An example permalink for something like this could be “” so we can at least have a mnemonic for when this happens next time. A more sophisticated method would be to do a version check on app start-up and put up a dialog box that says, “Steinberg Download Assistant needs to be updated.” with three buttons:

  • “Install automatically now” which installs the update and starts up dla,
  • “I’ll do it manually”, which leads to that dla_latest permalink, and
  • “Quit”, which allows us to terminate the app.
    Looking forward to that day!