Downloading installer of Cubase 7.5.3

Hi,

I need to reinstall my cubase 7.5 because I have upgraded my hard disk to SSD. My problem is when I visited your website and turn to the download section of cubase 7.5 , it seems that the webpage is not available. i tried it to many computers and even go to different internet cafe’s but the problem is still the same. it always shows me that the webpage is not available. maybe you can help me with this one. thank you very much

Hi,

It works here on my system.

Btw: The latest update is Cubase 7.5.40. :wink:

Kindly see the image attached. This always appears when im trying to download the complete installer of cubase 7.5.3
Screen Shot 2015-11-24 at 4.27.06 PM.png

I see, you mean the complete 7.5.30 ISO image. But even this one works to me.

I’m not this kind of expert. But if I just type the path from your screenshot, it downloads the ISO file, which is 4KB only. If I click to the link in the web page, it starts to download the whole ISO file (7.13GB). I don’t know why.

Hi Martin, Thank you for your effort, but i think my internet provider has a problem, doesnt allow big downloads, i tried to download the update 7.5.4 and its downloading.

I have a CD of cubase 7. do you think it will update it to 7.5 if i will use the 7.5.4 patch update?
sorry for bad english…

Unfortunately not. Cubase 7.5.40 update is an update of Cubase 7.5 only, not Cubase 7 update. You need the full Installer of Cubase 7.5

Hi Martin

Can you suggest any other way how can i get into cubase 7.5.3

what i only have is the cd of cubase 7. What i did the last time was downloading a update to 7.5 ( grace period)

thank you for your help

Hi,

The update to Cubase 7.5 was also the full installer, right? Do you still have this file downloaded, stored?

unfortunately i deleted them… =( i remember it was just 700mb update

Then I’m afraid, there is no way around, than download the big Complete Installtion (ISO) Cubase 7.5.30. Even on the 7.5.40 Update, web page, there is written: “This download updates an existing Cubase 7.5 installation to the latest version!”