Drag & drop MIDI Part naming

I’m dragging some midi files from Windows Explorer onto an Instrument Tracks which works fine. However instead of the Part being named after the midi file it gets named to whatever the Track is named - which means I need to rename each part back or I can’t tell the difference which gets old.

I thought there was a Preference that changed how the Part names were derived, but can’t find it anywhere. Am I overlooking something or just imagining things?

Hi Raino, haven’t done midi files in quite some time now but I seem to remember you need to tweak the following under Preferences -> MIDI -> MIDI File:

Especially the ‘auto dissolve 0 format’ and ‘destination’ settings?

Thanks, but that didn’t really help. These settings only seem to come into play when using “File/Import/MIDI File…” This will create a new Track which is named the same as the imported MIDI file, and then put a MIDI Part on that with the same name. Drag & drop names the new MIDI Part after the Track it was dragged onto.

The only other setting I can think of is Preferences > Editing > Parts Get Track Name. But I seem to remember it doesn’t always work as intended when dragging into Cubase as opposed from one track to another. Well, it’s worth a try?

Thought this must be what I’m recalling until I looked at my Preferences. It is unchecked and yet that’s exactly what is happening - the dropped part is getting the Track’s name. Then I remembered this is only for dragging Parts between Tracks - do they keep their original name (unchecked) or get a new name based on the Track name (checked).

It is entirely possible I’m imagining something that never really existed.

I’m sure that they used to keep the midi file name in earlier versions (say 5/32).
I know I’ve had the same frustrations in 7.0 & 7.5 (I skipped 8.5) and it’s still the same in 9.5.
Best solution I’ve found is to drag and drop into empty space in the project window. It retains the midi file name and creates a track of the midi file name. Then you can move it to the instrument track. Then you have the task of removing the newly created and unwanted midi track.
Frustrating isn’t it.

Just done some more testing because I seem to remember that I asked this very same question in, I think, version 7 forums, long long time ago.
Now to confuse the issue and throw in a question.

It’s working for me in 9.5 to drag & drop a midi file into an instrument track and retain the midi file name. But only with some purchased midi files. Other purchased midi files take the name of the instrument track.
I think that the question I asked years ago was “is there something embedded in the midi file itself?”
Maybe a red herring, but maybe worth pursuing.
Neil B

Well that is interesting.

For a handful of parts it seems like renaming vs. deleting tracks is a wash. But if bringing in a bunch of of files it probably is easier to delete the tracks all at once.

Raino, I knew there was something about this I’ve also been wondering about before in the past and I remember now? It’s a window 7 thing! I’m on 10, latest version. When I drag and drop midi files from Windows Explorer onto a track it retains the *.mid file name regardless of the Preferences > Editing > Parts Get Track Name setting. This setting will only influence the dragging from one track to another within Cubase.
I switched to Windows 10 early 2016 and when the occasion was there and I dragged a file from Windows Explorer I was surprised to see it kept it’s own name but didn’t pay much attention to it because I usually drag from programs like BFD3 & Superior Drummer3.

Interesting again, and yet I’m on Windows 7 and can drag and drop some of the midi files and retain the name of them.
Curioser & curioser, said Alice.

Awww, darn. For a moment it seemed like we had something that made sense.

Okay folks,
Raino & I have been doing some research into this and it seems that Nickeldome was the nearest to the solution.
I took the trouble of sorting out a midi file that DID keep its name and one that DID’NT.
I’d purchased these from Dance Midi Samples. Took the opportunity to ask them for any help.
This is the fantastic reply that we received from Peter, the MD.

Having had a quick read through the forum post you’ve quoted below, this seems to be a nuance of Cubase’s file handling. The good news is that it’s easy to side-step.
MIDI files will always have a channel name of some sort embedded in them (even if it’s ‘track 01’ or something even less descriptive), although the nature of this this may depend on which DAW the file was originally exported from - and whether the original producer gave the track a sensible name!
Taking the two files attached (one from DMS Epic Chords Vol 1, the other from DMS Progressive Plucks, Pads & Riffs Vol 1), I’ve imported each into both Logic X , Ableton Live and Cubase LE AI Elements 9.
Logic and Ableton import as expected, showing the correct names for each MIDI file by default.
Cubase however behaves exactly as noted in the Steinberg forum post - with some files taking the name of the Cubase channel, rather than the embedded MIDI file name.
From a bit of experimentation I’m certain that this is Cubase ignoring information in type 0 MIDI files.
Most DAWs give users the option of exporting MIDI as either type 1 (multi-track), or type 0 (single track only), although the option is often buried deep within layered menus.
I’ve attached 2 re-exported MIDI files from Logic, one as type 0, the other as type 1 - the type 1 version, at least in Cubase Elements 9, loads with the correct embedded name, despite the Cubase channel name.
I’ve also attached 2 ‘Test’ MIDI files, both of which contain embedded names - the type 1 file displays it’s correct name, the type 0, as expected in Cubase, does not.
I’ve managed to get around this issue by visiting Cubase -> Menu -> Preferences -> MIDI -> MIDI File, and unchecking the ‘Auto Dissolve Format 0’ option. This then allows Cubase to correctly import the MIDI type 0 files, with their internally written channel name.

I tested this and forwarded the results and test files to Raino.

It works fine. Nickeldome was on the ball with the answer - to a degree.
However, I’ll add a bit more to this now:
If you uncheck the autodissolve Format 0 and then import or drag & drop a “rogue” midi file, the midi file may appear on the wrong track and actually create 2 midi files. The other file contains SMF or sysex data only.
So, go to preferences midifile and tick “Import dropped file as a single part” and drage & drop again.
Job done.
Okay, preferences are supposed to be set and forgotten for the most part, but this is an area that’ll have to be changed depending on the midi files that you drag and drop. For instance, if you have a midi file with lots of parts (or stems), this’ll become messy. It’s a case of suck it and see when you drop the midi file in.
Hope this helps all who are interested and a big thanks to Dance Midi Samples for answering a query I’ve had for years (and for saving me hours of headaches in the future).
Hope this helps

Neil B

If you have a Preference that you will frequently change, assigning a Key Command to it saves lots of clicks. :wink:

Thanks guys, for the extensive testing and finally pinpoint the issue and of course coming up with a workaround! Some things you just can’t set and think it never has to be changed anymore? This is one of them. A key command for stuff like this is indeed a good idea.

OMG!!! I’ve been wrestling with this for hours,actually 2 days (on and off) and it’s been driving me nuts, (e.g. drag and drop MIDI not retaining original file name, adding an extra track with (look likes) nothing in it with the name, and then I ran across this blog! .

I’m using an iMac w/ Cubase 9.5, so I wasn’t getting my hopes up when you all started talking Windows 10 . But HATS OFF! to Neil B, Raino and Nickeldome for beating this anomaly into submission. What a relief! . I feel like what happens after a surgery with opioid constipation, and that gallon of laxatives you’ve been taking everyday finally kicks in! . (i.e.If you’'ve ever had to take pain killers for a few days after a surgery, you know what I’m talking about) …WHAT A RELIEF! .

Thanks so much again guys! . CHEERS!

P.S. what’s wrong with those Steinberg people, couldn’t they have pitched in, like a year or so ago?

Shows the value of forums that this is still helping people nearly 2 years down the line. You can come off the painkillers now SuziCube :slight_smile:

FINALLY!!! I’ve been struggling with this for 7 years!
This is Beyond Cool! Seems to be working on both platforms. I’m on a mac running 10.5
So far I’ve successfully dragged vendor named midi files from;
Addictive Drums 2,
Slate Drums 4 and 5,
Strum Session 2
File Names intact!
In Addictive, they show up with both the Library name and the midi file name!
Neat and tidy!!
Thanks, everyone for your relentless search for the answer!
Thanks, raino for keeping this topic alive!
and for your response to my post last month regarding the same topic!

So, to re-cap, In “Midi File”, we simply;
Tick “Import Dropped File as single Part”, then
Un-tick “Auto Dissolve Format 0” (theses are both set opposite by default)
BANG! Pretty damn easy!
Cheers.