Dragging midi from a software instrument does not work

Cubase 12 here…I am able to drag midi from one track to another if the source track is a midi track…but not if it is an instrument track. Is this expected or am I missing something? Thanks for any help.

There is certainly something wrong with your installation.
I can drag midi events wherever I want, as long as source and destination are midi or instrument tracks. Cannot remember this has ever been an issue on Windows.

Did you try to start Cubase in safe mode or start with trashed prefs (save them somewhere so you’re able to restore them), just so check if it works then?
If that does not solve it, perhaps a reinstallation might do the trick.

We expect some system information, at least.

1 Like

Thank you for the ideas. I tried safe mode and disabling prefs. Still no go. I can drag midi notes from midi track to midi track…I can drag midi notes from midi rack to software instrument track…but I can’t drag midi notes from a software instrument track to another pe-existing track, whether it is midi or software instrument. I CAN however drag midi from a software instrument track into the open space of the editor thereby creating a new midi track. Strange. I will a attempt a re-install.

Cubase 12. Macbook m1 Pro. MacOS Monterrey. 32gb ram. UAD Apollo twin. I am running native mode.

Should I assume you mean MIDI parts (as shown in the Project Window/Project Zone) and not actual MIDI notes?


Or even better:
Try to record your screen while doing that, so we can see it as well!

Here ya go…a YouTube link to a quick screen recording. Again…can drag notes to another track from the midi track…but can’t from the software instrument track.
Cubase dragging problem - YouTube

1 Like

That’s right ! I can confirm this !
We can drag notes from a MIDI Track to any other MIDI or Instrument/Sampler Track, which creates a new Event, but, when we do that from an Instrument Track or a Sample Track, the Event can only be created on a free space as a new MIDI Track. For some reason we simply cannot drop the notes into an existing track.
I will open a support ticket for this one.

Added to the issues list, number 40.

drag midi notes issue

I’ve never thought of doing that!

I didn’t even know this was possible. I thought it was about dragging events, not notes.

Alright, so the Support have answered and apparently it is not a bug but a feature request, and it needs to be tagged as such so the developers can see it. Period.

My guess is that it needs to have 50 votes and be on top of the list ?

Click here for more rage.

Here is my Support Request :


There is an issue where dragging MIDI Notes from an Instrument Track Event to another existing Track isn’t possible.

Reproduction sequence :

  • Create an Instrument or Sampler Track and record some notes,
  • Create a MIDI Track and record some notes.
  • Open the Key Editor for the Instrument/Sampler Track,
  • Select some notes,
  • Grab the notes to the Project Window.

    Result : It is not possible to drop the notes onto an existing track (prohibition sign), although it is possible to drop it on a free space to create a new MIDI Track.

  • Open the Key Editor for the MIDI Track,
  • Select some notes,
  • Grab the notes to the Project Window.

    Result : It is possible to drop the notes onto any existing track.

    This proves there is either a bug or a design flaw with the ability to drag and drop notes from an Instrument or Sampler track Key Editor.

    Here is the link to the forums :
    Dragging midi from a software instrument does not work

This is all explained properly right ? I have even sent the link to this topic so they could see the video.
Here is the answer :

Thank you for your mail.

That is not a bug. Cubase works as designated. It wasn’t possible to drag just MIDI notes to an Instrument-Track in previous versions of Cubase as well. You can only drag notes to a MIDI-Track, not to an Instrument-Track.

The answer was so confuse that it managed to confuse me for a brief moment too.
I then explained again the same stuff :

Thanks for the answer !

I think there is a misunderstanding.
It is totally possible to drag notes to an Instrument Track (which is the complete opposite to what you state in your answer), but only when the notes are dragged from a MIDI Track.

The issue is when we are trying to drag notes from an Instrument Track.
I have made a video showing the problem in this forum post. The file is too big to send here, so please read the forum page.

I have never said this was a bug, and as you say, this must be how it was designed, although, to me it clearly looks like a design flaw or something that has not been coded properly. It is not a bug that we can trigger by doing specific actions, here it just works like that by default, but not as most of the users would expect.
If we are able to drag notes from a MIDI Track, then we should be able to drag notes from an Instrument Track, this is just common sense, and I think we can only agree with that.

I hope the developers are aware of this, and will try to improve / fix it in one of the next updates.

And here is the final answer :

For feature requests, please use the corresponding section in the forum. Only here our developers will see it. Unfortunately, I can’t do anything for you.

Well, if your sole wish is to continue gatekeeping your issues, then my journey of gathering, testing and reporting them is very near to an end.

Sorry for the rage, but out of 30 bug reports I’ve made so far, only 3 have been told this wasn’t bugs but feature requests.
So far so good.
Keep calm and sleep good.

Don't click

Still, out of these three “feature requests”, 2 of them haven’t been answered by the same person as the 28 other tickets.
There is this one, where they won’t forward it to the developers directly, and another one (just a little bug) where I’m currently going through the full troubleshooting process (sending system info, reinstalling graphics driver and removing certain components that I actually need). We are almost asked to wipe the system and reinstall everything, just to troubleshoot one little bug that only exist in a certain place of the Cubase 12 software. Obviously I didn’t reinstall or removed anything, I have so much other programs that need this stuff, I won’t remove anything just to troubleshoot a simple bug that consists in five pixels disappearing. The heck. I even asked two times if they were able to reproduce the issue and they just ignored my question.

Hopefully the third person gave me CAN numbers for every other issue and reported them to the developers, without asking for anything else, except when it needed some clarifications.
I’m not criticizing anyone in particular, they are only doing they job, but when I spend three hours a day trying to find if that or this issue is a real bug in the software or not, I just don’t like spending as much time getting asked to remove the drivers, or “that is not a bug, I won’t forward it”.

Alright, have a nice day guys,