Drum editor/Key editor lower zone vs editor window

When selecting a midi track, the lower zone automatically switches between drum or key editor. How do I get the key editor window (separate window) to mimic this desired behavior?

If you add a Drum Map to a MIDI or Instrument Track, then the default editor changes and double clicking an event will open the Drum Editor rather than the Key Editor.
Is this what you’re asking for?

I don’t think that was the question as the user was already using that method but wants to know if it can also be done on the editor opened and not the bottom pane. In the bottom pane once open you can click between parts and it will change to whatever part and you select. So can go from drum editor to key editor for example without any double clicking once the editor is open in the bottom pane.

To answer I don’t think you can do this if you select an editor from the midi menu.

Since there was no mention of Drum Maps in the OP, I though I’d share that tidbit of information.

But no, the Key Editor window can’t change to a Drum Editor. I think the reason is that they are individual windows as opposed to the lower zone which is a container that can hold several different windows. You can have a Key Editor and a Drum Editor (and a List Editor for that matter) open at the same time.

It does work (Cubase Pro 12 here - the OP didn’t specify). The prefs need to be set thus for this to work:

2 Likes

Nice one. I might try that myself.

A side note. I must have changed a setting recently as every single note is being followed so I have to stop Cubase to edit other notes. I can’t seem to find the setting to change back to just following but not selecting each note as it does. Probably staring me in the face or named something I’m not expecting.

Just looked and I had already enabled it trying to find my problem. I thought it only applied to the lower zone. Yes it does work.

These same preferences are available in Pro 11 (and I have them set exactly as shown) . This still doesn’t allow for the same behavior as the lower zone.

The lower zone automatically switches back and forth between drum editor (when selecting a track that has been assigned a drum map) and key editor (when selecting a track that has not been assigned a drum map).

I cannot get the key editor (opened in a separate window) to behave in the same manner.