Drum Map Stopped Mapping Properly

Hi all,

Problem: I created a drum map a couple of months ago that worked then. I pull it up now and nothing is mapped properly anymore.

Drum Instrument (midi input): Roland TD4s
Drum VST: Addictive Drums 2

Here’s a simple example (refer to the screen cap below)

  1. The TD4s snare pad sends a D2 note.
  2. The AD2 VST snare responds to a D1
  3. The Cubase DRM (in Drum Map Setup) has D2 in the I-Note (Input) column and D1 in the O-Note (Output) column (see image, center)
  4. I confirmed in MidiOX that the TD4s snare pad generates a D2 note (see image, right-side, last line)
  5. While recording and hitting the TD4s snare pad, Cubase records a C3, which is mapped to a ride cymbal (not bongo) as the drum map in the image indicates for Ride Cymbal 1.

Also, the tom pads seem to record with their original pitch note (generated by the TD4s) and are not mapped at all, so they’re playing what happens to be there for the I-Note value.

I’ve tried creating a completely new drum map, muting all instruments except the 8 pads/controllers for the TD4s kit. In this new map, I was successful in mapping D2 to D1 that worked (triggered the AD2 snare), but I couldn’t get the others mapped for some reason (as if the mute doesn’t resolve mapping conflicts).

If I had a good understanding of what’s going on, I could work with this to fix it, but why it suddenly stopped mapping properly is lost on me (again, it worked fine the last time I used it a couple of months ago).

Does this ring a bell with anyone?

Thanks, Chris

It sounds like the incoming Note is being modified at some point. Three suspects come to mind.

  • The Track’s Input Transformer
  • An Expression Map
  • The Track is set to follow the Chord Track

Has nothing changed? Did this change on the latest Cubase update? I’ve used this feature a lot and never had a problem but I now do the mapping in sd3 so not recently.

Thanks for the suggestions raino, but they didn’t pan out. The transformer is set to off and there is no expression map.

The Chord track thing sounded interesting because I created my first chord track with my current project. But I am now testing this in a new project with just the drums and no chord track. Plus, the AD2 drums track has “Follow chord track” set to “off”.

I thought that since I had some issues with the chord track, I might have set a global preference, but I can’t find any. I did play with Adaptive Voicing back then (because the bug where the chords increase pitch to chipmunk ranges), but that shouldn’t apply to this test project (with no chord track) and I turned that off in the one project with a chord track.


Hi mkok,

I believe that the DRM worked fine when I created it and looking at the file date, it’s only a month ago back at the start of December (not a couple of months back).

I did upgrade from Cubase Pro v11 to v12, but I think that was back in the sprint (official release date was March 2022, according to Wikipedia).

I did purchase and install my first version of WaveLab Pro, but that was back in November (before the DRM file date).

I can’t think of anything else that changed. As I mentioned to user raino above, I did create a chord track for my current project, but I’m still having this issue on a fresh test project with no chord track.


If I get a chance I’ll see if mine does it. I have Wavelab pro and have for years. I can’t imagine that could do anything

Okay, I’m on to something. My research isn’t complete, but I wanted to update this thread to keep anyone else from doing any work that could be wasted.

The tact I’m taking (and it does not in any way explain why my old map worked) is as follows.

  • Using a full map with no mutes is a nightmare. You can make a change that you think would fix it, but a mapping conflict elsewhere exacerbates the problem. It’s as if whatever is mapped though the DRM is re-submitted to the same DRM–I’ve traced some sounds through three different levels.
  • So I started fresh with a new Drum Map with ALL sounds muted and am only unmuting as I test each TD4 pad with it’s corresponding AD2 sound.
  • I’m ignoring what note the TD4 kit sends out (as per MidiOX), as it will still be received (pre DRM) a full octave lower when it’s recorded. So I’m using the note that Cubase records. (On this point: I have now seen other videos where people point out how Cubase sounds are off by one, but mine are off in a different way; for example, a D2 as shown by MidiOX records as we D1).

I’ll recap when done for the benefit of future readers.


Just to clarify this: Cubase is not exactly “off by one” but it has a naming scheme that is off by one octave compared to some other programs. What other programs call C4 is called C3 in Cubase but the numerical value for the Note-On event is the same. It leads to confusion, of course, as we deal with note names rather than numerical note values. You can find references like C3=60 (Cubase, I heard also Logic, Ableton Live) or C4=60 (MIDI-Ox).
Maybe the MIDI Specs were not crystal clear in this matter.

Anyway, on your screenshot the last event in MIDI-Ox was D2, which would be a D1 in Cubase. D1 is routed to C3 in your drum map, thus High Bongo is played back.

You can change MIDI-Ox: Options → General Options… → Middle C Octave


Thanks Johnny,

That explains a lot.

While mine was as you explained (D2 = D1), the “off by one” thing can be found in the following video. I’m not sure how note name vs. numerical note values correspond. There are 12 notes in an octave, so that set expectations for me initially, but the off by one (not 12) can be demonstrated in this video starting at time index 4:10. Except that the offset doesn’t always happen

Thanks for the pointer to changing the MidiOX setting, but that’s not something I want to do since I use that app for other devices (I would not want to forget the change it back and have confusion down the line).

At any rate, this issue is resolved. The answer is to not trust what note value your controller is issuing, but rather the values that Cubase records. And for me, working with a map with all instruments muted worked best.

The other thing that was not resolved for me (besides the fact that my first drum map seemed to work a month ago), is having mappings that don’t work even after realizing what values they are, due to mapping conflicts elsewhere in the DRM map. I may be wrong about that, but if a note IS mapped through the matrix more than once, that’s a bug.


That is pretty easy:
MIDI transmits a note pitch as a value from 0 to 127. Programs like Cubase and MIDI-Ox “translate” that number into somethhing more musical.
Cubase names note 0 = C -2 (negative 2), while MIDI-Ox with its default settings names note 0 = C -1 (negative one).

This should be regulated in the MIDI specifications from the 1980’s but maybe it is not clearly written down there.

Regarding the offset by one number: I’ll check on that later.

1 Like

Ah right. I thought this had originally worked and then stopped but from what you are saying this would have never worked with the method you used. As far as I can remember back when I first get Cubase early 90s this has always been the same. I’ve always used the note number Cubase records.

With edrums where it’s individual amply I have my own list of the notes from my td30 which I record and then name. From there I map. I did that back when I had an Alesis D4 and a Roland spd8.

Glad you got it sorted for you though.

1 Like