Drum plugin port unmapped when adding VST

Hey all,

Suddenly my Cubase 5 acts strange and I hope anyone can help me.

I’m using EZdrummer 2 as my drum software. This plugin runs perfectly fine with Cubase 5, but when I add VST-effects to the seperate kick, snare, hi-hat etc. and save this, the next time I open the song in Cubase, I get the message that EZdrummer can not be found and that the port is unmapped.

Because of this, when I open my song, I have to reassign EZdrummer as my VST-instrument, open my previously saved drumkit, copy the drumtracks to the new VST-instrument and reset my VST-effects to work again with my song. This is very irritating as it re-occurs every time.

How can this be? What am I doing wrong? I’ve been busy for weeks to find out if my correct plugin folder was set, so that’s not the problem anymore.

The strange thing is, that when I don’t add VST-effects to the drums, there is no problem at all. So in some way the added VST-effects disturb the plugin from working.

Please help!
Steven

Please list your system specs and some specifics about the vst-effects you are trying to use. Also, is this a new issue or has it never worked right?

A few general thoughts:

  • Maybe mixing 32 and 64 bit vst-plugins/effects is causing an issue?
  • Are all the plugins you are trying to use together set to “Run as Administrator” (windows o/s only)?
  • You said the EZD2 works good with no added vsts but, do the vst-effects you are trying to add work well on there own too?

Regards :sunglasses:

Hey Prock,

Thanks for your response. Here are my system specs:

DAW: Cubase 5.1.1
OS: Windows 7 x64 SP1
CPU: AMD FX™-8350 Eight Core 4.0 GHz
RAM: 8 GB
AI: Tascam US-122L

The VST-effects I want to use for my drums are:

Roomworks
Roomworks SE
VST Dynamics
Multiband Compressor
GEQ-10 Equalizer

  • How can I see if VST effects are 32 or 64 bit?
  • How can you set plugins as ‘Run as Administrator’? I never saw any option like this…

The VST-effects work perfectly fine when I use them for recorded vocals or guitars. What I do is that I made certain VST user presets. For instance: I made a preset called ‘Kick’, so when I add this preset to the kick, the pre-delay, reverb and compressor are simultaneously set for the kick. I have a maximum of three VST-effects running per drum item.

I hope you can spot something I do wrong!

Cheers,
Steven

Hi Earial,

The effects you listed are all from Steinberg and they do work well with EZD2. At least they do for me when using my CBLE4 and CB7, CB7.5 & CB8 series. I use them quite a bit and never have a problem. So, let me first say that I don’t specifically have CB5.1.1 but… I would think they should work (pretty much the same) with that version too.

1st… let me get to your easier questions:
Now that you mentioned more specifics this one probably DOES NOT APPLY to your issue but…
How do I tell if a vst is 32 or 64 bit? Of course this took place when you 1st installed the software and you chose install as 32 or 64 bit. So the only method that I know of now is to check what folder the program was installed to. Generally speaking, if it was installed to the “Program Files” folder it is 64 bit. If installed in the "Program Files (x86) folder it is 32 bit.

This one MIGHT BE CAUSING your issue so you should check this out…
How do I set software to “Run as Admin”?
You should do this for all your music related software like Cubase itself and all plug-ins that have a stand alone version that are installed (like EZD2). So do this at least for your Cubase and EZD2 programs to assist with your specific issue.

  1. Right click on the program icon
  2. Choose “properties”
  3. Choose the “Compatibility” tab
  4. Check the box “Run this program as an administrator”
  5. Optional… Choose the “Change settings for all users” box
  6. Check the box “Run this program as administrator” box
  7. Choose the "OK"s… That’s it, you are done.

If you had to set either program (CB or EZD2) per the above steps then go check to see if your issue still exists. Hopefully it is fixed but if not… here is how I get mine to work perfectly.

  • I use EZD2 on a “instrument” track. Not a “midi” track.
  • To assign the vst-effect I click on the “e” (edit channel settings) button. Then I choose (for example) RoomWorks SE from the inserts dropdown menu listing in the channel settings. Activate the effect. Adjust it to my liking. Close the plugin control box. Close the channel settings box. Then hit file/save. If you don’t save the project at this point you may get the issue you described. So save it at this point before doing anything else.

That’s it. Hopefully you are all set. :wink:

But…

If there is still an issue I offer this work around…

Bounce your EZD2 midi tracks to audio tracks. You did say that the vst-effects work for audio tracks (like vocals or guitar). So assign them to the (now) audio tracks and voila’, you should be all set. :wink: :wink:

Good luck.

Regards :sunglasses:

Hey Prock,

Wow, thanks a lot for your detailed answer! I decided to work in clear steps and update you on my findings. So here’s step one:

  • I checked all the boxes of my stand-alone programs (Cubase, EZdrummer etc.)
  • I only set VST’s on the kick channel, I saved, closed the program, re-opened it, it worked!

Step two:

  • I restarted my pc, opened the song: it worked!

Step three:

  • I added al other VST’s to the kick, snare, OH etc. I saved after every setting every VST-selection. I also renamed the drumtracks from ‘EZ1’ to ‘Kick’ and EZ2 to ‘Snare’, so I can easily see what I’m doing.
  • I saved everything, closed the program, re-opened: failed…

Step four:

  • I went back to the point it all worked: I set VST-effects only for the kick and didn’t rename anything.
  • Restarted: all works like it did before!
  • I added the other VST-effects (to the snare, hi-hat etc.) and I didn’t rename anything.
  • Restarted: failed…

Do you have any new insights yet? If not, I will try your next option: set the drums on an instrument track.

Thanks, I feel we’re close!
Earial

Earial,

I do things pretty much exactly to what you describe in steps 3 & 4 and mine works perfectly. I have never had a problem using my EZD2 adding several Steinberg vst effects when necessary. So, I am out of new suggestions. But please make sure the EZD2 tracks are created on an “Instrument” track. Not a midi track. Also, I did think that this was not applicable but maybe you do have some kind of conflict between a 32 bit CB install and 64 bit EZD2 install (or vice versa). I guess you need to investigate that too. My CB and EZD2 are both installed as 64 bit. Man, what a PIA.

Of course you could do the bounce to audio work around but, it should not be necessary and, to be honest, creates a few extra steps. But, I suppose you gotta do what you gotta do.

I hope someone else will chime in here to assist with this puzzling issue. If no one chimes in maybe a communication to Steinberg support might be fruitful.

If you ever do get this sorted out please post what you found.

Good luck.

Regards. :sunglasses:

Hey Prock,

Thanks for the advice. I will try the other remaining tricks you pointed out and I will keep you updated. I know I installed EZdrummer as 32 bit.

Greets,
Earial

Hey Prock,

Today I tried the other options: I made an instrument track for the drum tracks and I dragged my drumtracks to the newly made instrument track, but then I can only hear the kick if I set EZdrummer to ‘Multichannel’. I can hear all the drums when I set EZdrummer it to ‘Stereo’, but then I can not add VST’s to the seperate drum tracks.

Also: when I want to switch EZdrummer to an instrument track, should I delete it from the VST-instruments? I tried with and without deleting, but still no results that make me happy :frowning:

Then I saw that all my seperate drum tracks (kick, snare, hi-hat) were already set as an instrument track from the start, so only my main EZdrummer track is now on Midi, which is the only one that let’s me hear all the drums and has the ‘add VST-option’.

I also checked where I installed Cubase and it’s in the x86-folder, as well as my EZdrummer 2.

Then I’ve been experimenting with VST’s. When I set up VST’s for the kick, it all works, also when I restart. When I only set VST’s for the snare track, it fails. It also fails when I set up VST’s for the kick and snare. Can be that it has something to do with the multitracking?

Regards,
Earial

Let me explain again how I get mine to work perfectly… :wink:

Working on an “Instrument” track:

  • Open your EZD2 and go to the “mixer” tab.
  • There, you can choose where each instrument channel will appear in Cubase
  • Choose the dropdown on the 1st channel (the one on the left) and choose “multichannel”. That will assign a separate track to each percussion instrument.
  • Now, when you drag a midi from EZD2 to the instrument track CB will create as many tracks as necessary for each separate percussion instrument in the midi file you placed on the CB instrument track. These tracks will by default be labeled whatever you named the instrument track then EZ2, EZ3… etc.
  • Highlight the first percussion instrument track.
  • Click on the “e” button to edit the channels settings.
  • Choose from the “inserts” tab as many effects as you want to add.
  • You can save this as a track preset at this time.

HERE IS WHERE YOU MIGHT BE MISSING THE STEP…

  • Before closing any window or messing with any other track go up to the Cubase taskbar and choose file>save (the whole project).
    If you don’t save the project NOW you might get the issues you describe.

  • Edit other tracks as you want but always do the project save after editing each track and before closing any windows.

  • Now you can close any window, close CB, restart the computer, whatever you want. And when you restart and open the project the setting should be there.

If not, then maybe a reinstall of CB or EZD2 is necessary.
Also, although I never had to do it, it seems like there are quite a few topics on this forum that say to delete your CB presets or preferences file. Maybe that would help. I don’t know if it would and I don’t how to do that. You’d have to search for those topics.

So, again, I hoped this helps you with this issue. At this point I am plum out of new ideas.

Let me know if this explanation helps or if you figure out what the heck is happening. :slight_smile:

Regards :sunglasses:

Hey Prock,

Thanks again for your endless patience… When you say ‘Open your EZD2’ for me, I assume you don’t mean the stand-alone version, do you? The only way I can open EZD2 is to press F11 and add a VST-instrument. When I do this, Cubase always asks if it should create a midi track for it. I always press yes and then choose ‘activate all outputs’. If I press no and I create an instrument track, I can only hear the kick, even if I put it on multichannel in the EZD mixer. All the levels of the kick, snare, hi-hat all respond in the EZD-mixer, so there’s a signal broadcasting, but Cubase only plays the kick… I’m also very accurate with the saving process, so that one can also be crossed out.

I think I will prepare myself mentally for a complete reinstall of Cubase and EZdrummer 2, but my biggest fear is that it will be just the same if I put everything back… I will put all the preferences in Cubase to default first.

I’m so sick and tired of this… I just want to make songs :frowning:

So when I’m reinstalling it, I will do everything on 32 bit: Cubase and EZD2.

I will keep you updated!
Earial

When I said open EZD2 I meant the vst-instrument opened from the inspector section of an existing CB instrument track. Not the stand alone.

Can’t hurt to look at this vid to see if you are doing anything out of the ordinary. It shows how to create muti-track drums using ESD2 in instrument and midi tracks. However, the vid does not show connecting multi vst-effects but it still might prove useful. Again, good luck. :slight_smile:

https://www.youtube.com/watch?v=musu_nguzuc

Regards :sunglasses:

Hey Prock,

Break through here! I think I got it working. I fixed it five minutes ago and then I saw your last reply. The whole issue is caused by the way I save the VST-effects.

What I normally did:

Go to ‘kick’ channel (EZ1), clicked on my user VST-preset for the kick in the inspector area (includes three VST-effects) => in one click the three effects were set for the kick. Then I clicked ‘save’.
Then I did the same for snare, hi-hat etc.: every time I added three effects to the channel with one click and then clicked ‘save’.

When I opened the song again it would unmap EZD.

What does work is adding one effect at a time and then click save after adding each seperate VST-effect to EZ1 for example. The weird thing is that the three-in-one-click does work with the kick, but when I do the same for EZ2, EZ4 etc. this three-in-one-trick causes fails and EZdrummer 2 gets unmapped.

Right now I added and saved all my effects one by one, opened other songs and then the song again I was working on. Restarted Cubase several times, restarted my pc and still everything works! I can’t believe it.

I hope it stays like this and doesn’t change over night… Too bad I can’t use the three-in-one-trick. Does that work with you?

I’m glad I waited with reinstalling and you absolutely made my day, week, month, months…! I guess the big question is: WHY??? (screams in universe with slow dark voice and lots of Roomworks SE). Let’s wait a bit with closing this matter. I can only comprehend after I’ve worked with it a few times without hassle…

THANKS!
Earial

Earial,

Really glad you got this to work. Even if not the real way it should and does on my system. At least you can get back to making some tunes. :wink:

I want to confirm for you that on my system I can add a saved preset that has multi vst-effects (I have presets containing 2 to 4 effects) to any of the drum tracks using one click. But then I must save the project before going to the next track to add the same or a different preset containing multi vst-effects. Again, I save the project after doing each track.

Just so you know… I got into the habit of saving the project after “editing” each track after I noticed that multi vst-effect assignments were not saving properly. Sometimes (but not always) the vst-effects would not be saved if I edited several tracks before saving. However, I never had a problem where EZD2 itself would get unmapped during this process.

For me I have not yet had any issues with EZD after updating to EZD2. Before upgrading to EZD2 the original EZD would sometimes get unmapped when I used a specific older 32 bit vst-instrument named VB3 on a different instrument track in conjunction with EZD on its track. For me that issue is long gone as now both VB3 and EZD2 are both 64 bit installations.

Regardless… Again, glad you got this sorted a bit and if you have any other questions feel free to ask. I only hope I can assist.

Regards :sunglasses:

Hi Prock,

Indeed: when I was working with EZdrummer 1 I never had any issues of this kind and now I got a load of problems to overcome, but it now works.

Thanks a lot for helping me. Experts like you are pretty difficult to find! If I’m in deep trouble again and I can’t fix it myself, I will let you know.

Cheers!
Earial