Dual core CPU for cubase 11 artist

Hi there! I am setting up a home studio on a budget and got myself a cheap refurbished laptop which I thought would have good enough specs but I’m not so sure about this now.

I was about to purchase Cubase Artist but saw that some people already had troubles running it smoothly with processors far better than mine.

The laptop I have is a HP zbook 15u g3 with 500GB SSD and 16gb RAM, but the processor is an Intel i7 6500u 2.5Ghz - 3Ghz 4mb cache and 4 thread.

Now most of my projects would be around 30 tracks for now, and I saw that freezing tracks can help with the CPU.

Would I realistically be able to run it smoothly enough?

You happen to have a similar setup than my laptop.
I also have CB installed also on a much bigger full tower, but I find myself using only my slower laptop, and am quite happy about it. I have not used my tower for years now…

My laptop CPU is a bit better than yours (see details below), but I have half the RAM and drive a 4k monitor.
I run CB Pro with 20-30 tracks without problems, or should I say, no issue I can easily work around.

The main trick is to have a clean Windows installation, i.e. run task manager to identify and remove all the useless junk that may be wasting CPU cycles in background. Whenever you encounter a CPU problem, run Task Manager, find the culprit and uninstall it. After a little while you’ll have a much better machine.

Beware also of anything said to be “automatic”… an automatic update of Windows or your virus scan starting at the wrong moment might ruin a recording…

I use very large sample buffers when doing everything except recording (don’t care then for latency).
When recording, then only I reduce the sample buffers to reduce latency, and I mute tracks and/or freeze them when/if I get issues (drops).

To be frank, I would not have recommended buying this laptop, but it is absolutely usable for most (or any?) medium size CB projects, if done right. Give it a good try with the suggestions above and you might be very satisfied (with a minimum of patience of course).

CPU comparison here:

oops, didn’t copy the column headers

image

Great! Thanks that’s very helpful!

I think I’ll get the trial version and and try all the tips that you gave me! Hopefully it will work!

But I’m thinking that yours runs smoothly because your CPU is a quad core?

But we’ll see.

Thank you so much

But yours support hyperthreading, mine does not…

Testing with the free trial is a good strategy, but I’m confident it can work, albeit with limitations.

Again, uninstall (or disable) everything that is not needed to CB work, preferably before you start installing CB.

In the Performance tab of Task Manager, you should see a nearly flat line at 2%-3% for you CPU. If not, open the Process tab to find the culprit and remove it. (or disable it)
Check the Startup tab also to disable unnecessary CPU parasites…

That’s a good machine. The Zbooks are made with CAD, Maths and Engineering work in mind and are good choices for DAWs. You’ll be fine unless you’re running loads and loads of VST instruments. For regular tracking and a resonable number of active plugins you’re well within the recommended system specs. Bussing multiple tracks to delay and reverb FX channels can help save on systems resources. You could also consider Reaper which is much lighter on computer resources than any other DAW.

Received my laptop yesterday and started messing around with CB trial version! Quite a lot to learn!

I followed your advice about having a clean CPU and all, and it works fine for now, so thanks for all that! :+1:t5::sunglasses:

Yeah I heard about bussing so trying to use that in my productions.
And yes you were right the computer is good enough for what I’ll use it for. So thanks!

2 Likes

Hi Mickael – no worries!

Kind regards,
Canaan

If yours supports hyperthreading then turn it OFF!

Hyperthreading works by hijacking cores that are apparently idle.

When you start Cubase it will have fresh, unfettered, use of cores, but after a short period, background processes will notice that a core used by Cubase is idle and begin hyperthreading into that core. You’ll then get ASIO glitches despite a high buffer size or high latency values selected in your ASIO.

Hyperthreading misbehaviour in Cubase playback (or record) looks like this: 1) No gitches in the first minute or so of playback in a newly opened session. 2) increasing frequency of ASIO glitches there after as hyperthreaded background processes hijack the cores for their own use. tTurning off background processes in WIN 10 also helps, but it doesn’t turn off all background processes (WIN10 housekeeping) so it’s less effective without hyperthreading turned OFF.

My rig is a lowly ThinkPad x220 i7 with 8gb ram running CB 11 pro that is totally glitch free down to 128 buffers with 3ms latency for record and playback using lowly ASIO4ALL (instead of my interface specific ASIO) - BUT only since turning off hyperthreading in my BIOS setup.

Oh interesting. I haven’t had any glitches so far, but I’ll keep that in mind.

I’ll check my settings and see!

Thanks for the tip!