Dynamic System Objects?

For some reason, there is one staff at bar 943 (rehearsal letter G) that is not going away. It is clearly empty and I am not sure what is lingering to keep it there. The layout rules are set so that it should disappear…and yet. Any idea what might be happening?
Dorico Foum - top staff issue.dorico (2.0 MB)

In Layout Options > Vertical Spacing > Staff Visibility > Players excluded from hide empty staves … the Clarinet is checked.

sorry, this for the Piano Vocal Score layout?

The problem is that the lyric “thing” in the preceding system actually has a duration of 10 bars - if you select it and look in the status bar you can see it will say “Bars 941-951”.

1 Like

Hey can you clarify, I’m trying to figure out what you mean but am not finding anything in the status bar.


Now that I see where the problem is — I tried various ways of fixing the duration, most of which do not work. Dorico seems to be more stubborn than it used to be about this. I select the syllable, and:

  • Hit Enter and Space in the popover
    – This leaves the extension the same incorrect length
  • Shorten it with Shift-Option-left arrow
    – This refuses to shorten it enough, to its proper length
  • Cut and recreate it
    – Same length again, all the way to the next word at bar 951

I found two ways that do work:

  • Delete it, untie the note, recreate it, retie the note
  • Cut both syllables of the word and recreate them both

Shift-Option-Left does work, but the syllable’s 10 bars long so you’ll need to press it quite a few times, or change the rhythmic grid value first.

1 Like

Unless I’m mistaken, it’s due to the lyric extension searching for the next note to end on, rather than ending at the rhythmic position straight after that particular note.

To check, I normally just add a note directly after where the lyric needs to end (the lyric extension will snap to it), and then re-input the lyric so that it ends on that note, and then remove the extra note.

1 Like

I select the syllable, hit Shift-Option-left with a whole-note grid, and watch the extent change in the status bar, and the empty staves disappear as I go. When it gets back to the downbeat of bar 942, I switch to an eighth-note grid and continue trying to shorten it, but the line will not shrink any further. It stays extended under the half rest.

Here’s a third one (and faster, I think):
Double click the “some ‑” syllable, press -, press enter. That cured it for me (in galley view, not sure it matters).

NB: I tried to reproduce it and it did not work. What does work and is even simpler
Select “thing___”, enter (or double click), press space. That’ll get you to page 11, but when you come back, everything is correctly set.

1 Like

Does anyone know what might have caused this. I sent the dorico file back to the composer and months later it came back with all these little nits floating around. Any idea how this happens?

It’s unfortunately a problem that can occur if you use the spacebar during lyric input to advance across a rest (or several rests) between notes. It’s something we would like to improve (our ref: STEAM-10274) but it’s not totally straightforward.

1 Like