Each time Cubase starts the CC121 Remote Device's MIDI Input change back from Bome's Virtual Midi port to Steinberg CC121

Hi all!

For me, the AI knob’s speed sensitivity curve is unusable. I have to rotate it totally 3-4 times to turn one round on the VST parameter.
So I set up a new MIDI translator in Bome’s MIDI Translator Pro software.
It adds a “little magic” to the original Midi CC’s and routed to a new virtual MIDI port.

In Cubase’s Remote Devices config panel you can set up the CC121’s MIDI input port, so I selected the new virtual MIDI port as Input.
It works great, until you are restarting Cubase.

After the restart you need to change it again manually to the virtual port, because something overwrites your “saved” settings with the original CC121 MIDI Input port.

Of course I totally disabled the CC121 MIDI input port in Cubase, but it didn’t helped.

I’m afraid this operation burned into the cc121_extension_u.dll.

Have you got any idea, how can I really save my MIDI Input port setting ?

Steve

Unfortunately, the CC121 extension will grab the device automatically.

I’m not using the CC121 these days, but I presume the CMCs work in the same way. When I want to do custom stuff using Bome, I remove the device from Studio Settings after launch.

Thank you for your reply Steve! Yes I did same after every launch. Finally I patched the extension dll, so it already works well.