edit instrument channel setting e button looses midi

Hi, new to the forum, sent a support request to steiny but no answer, can any one help with the following sent to steinberg support, also put a post on kvr about this…ps, it’s cubase 5.1 i’m using…

Subject: edit instrument channel setting e button changes looses midi channel connection, no audio to tweak

I do this…

  1. assign a synth/vsti to a midi channel, i can play midi
  2. bring up the mixer, i still have midi from my synth/vsti channel playing
  3. press (e) on the channel that assigns the vst effects to my synth/vsti, otherwise known as ‘edit instrument channel settings’, My synths midi channel does not play anymore, the channel that is live has switched to the channel of the vst effects.
  4. I cannot switch back to the synths midi channel while the eq/vstinstrument channel settings window is open, so cannot tweak the eq whilst playing the synths midi channel
  5. If I choose a vst effect I must close the ‘vstinstrument channel settings’ window, then keep the vst effect(i.e. reverb etc) open, then click on the syth/vsti’s midi channel, then I can tweak the effect whilst playing midi…

Why does pressing (e) to bring up the ‘vstinstrument channel settings window’(where the eq window is) change the live channel to that, I cannot play midi of my synth/vsti whilst that other window is open, i.e. cannot tweak eq whilst synth is sounding, impossible to do, never happened on my old set-up like this, just this new pc I have bought?

I tried the box disc, same problem, I cannot use 5.5. because my Plugiator hardware’s vsti is not compatible with it so need a fix within 5.1.

Await your reply, thanks XXXX XXXXXX…

That’s just the default behavior for a VST instrument that has been set up via a MIDI channel. Since you cannot apply audio processing to a MIDI track, the Channel Settings window will only be available to track types which output audio. So, when you press “e” to bring up the Channel Settings window, your MIDI channel loses focus to the linked instrument channel. To keep Cubase from doing this, go to File>Preferences>Editing>Project & Mixer, and uncheck “Select Channel/Track on Edit Settings.” Now you can highlight your MIDI track, and then press the “e” that is linked to the instrument output settings.

Alternatively, you could try using an Instrument Track instead of a MIDI track linked to your VSTi. It will achieve the same results with fewer unnecessary lanes (unless you need multiple outputs for your instrument).

My name is XXXX -XXXX from northern Sweden.
Thank you so much for your instruction to solve the problem with the “E” button that would not work. Having had a problem with Cubase 5 studio quite a while. But at last, the program works well.
Thanks again
// Anders :smiley: