Edit > Range > Insert Silence ... What might keep it from working?

Hi - I’d like to insert 32 bars of silence so I can add a repeat of the verse and bridge. I’ve created a range of that length all up and down the project, unlocked all the locked tracks and enabled all the disabled ones, but the command doesn’t work there.

I’m able to have it work on the odd audio track, but not the whole project.

Any hints for what I’m missing would be greatly appreciated - thanks in advance!


Have you selected your range in the ruler or on an item? Not at computer now but I’m pretty certain it needs to be marked in the ruler.

Ok, thanks @Sibben !

I just opened the range on the top track and dragged all the way down (including all tracks, even tempo, sig, marker, etc.)

I’ll try the ruler instead.

Thanks again!

Yeah. Don’t select anything in the arrange window. Just the ruler. There’s two kind of ranges. Cycle range up top and, well…item range or sumthin sumthin.

Apologies, I’m not understanding how to do it.

The manual , at least on .pdf page 254 isn’t specific enough for me to understand.

One guy in a youtube manually extended the range all up and down to do it, but it was an old vid.

Can anyone give a “repro”-type set of instructions if they had a moment please?

Thank you!

You need to use the locators, so put the left locator where you want the silence to start, and the right where you want it to end. Then you can use the range → insert silence command. The range does not have to be active.

At least that’s how I do it - there may be other ways!

1 Like
  1. Move the mouse to the very top of the arrange window, just above the numbers. It becomes first a cross and then a pen.
  2. Draw a range with the pen. Any length will do. A bar will appear with white triangles on each side.
  3. Move the triangles. The left one where you want silence to start. The right one so the length of the bar is the same as the length you want to insert.
  4. Edit → Range → Insert silence. Stuff moves now to make room for the time of the range bar you made.

This is the easiest way. For some reason the command is sometimes greyed out. I’m not sure why so I just fiddle around until it works. Cubase is a quirky old beast.

1 Like

Hi @Sibben -

Thanks for the step by step!

Turns out that’s just what I’m doing, do a tee.

EDIT: I’ve posted a vid in the following post showing what I’m doing.

Thanks again!

Hi - I made a vid of my steps (thanks, @steve for instructions in the other thread!), I hope it shows what I’m doing wrong … thanks!

EDIT: I should say … all tracks are “enabled”, despite track names being labeled “disabled”, if that makes any difference. Additionally, no tracks are “locked”.

That is super weird. I have no idea why nothing happens. Maybe someone else knows. :confused:

1 Like

I have no idea either.

What I would try is copying the project and taking elements out of it bit by bit until it works - or not!

I would start with deleting old track versions on the signature and tempo tracks.

1 Like

Do you have any locked elements on the timeline? I seem to recall that they will prevent this as well as some other operations.

1 Like

Thanks @Sibben , @Jason_Staczek , and @RichardTownsend !

I did an “unlock all” so i don’t think that’s the issue (?)

It’s a brand new C12 project with track imports from C11. I’ll check if there’s any track versions involved.

But if that’s the problem … not being able to “insert silence” in a project with track versions seems quite restrictive!

Did you try it this way?

1 Like

Track versions are usually fine, AFAIK. I mentioned the tempo track and signature track because I’ve not used versioning on those myself so it simply stuck out as something unusual.

Another wild guess - do you have locked events on any older track versions? I’m wondering whether unlocking a track will perhaps leave those alone and so you still might actually have locked events.

1 Like

It works now.

  1. Events in closed folders do not get unlocked with Select All > Edit > Unlock. On my system if there is a locked track the Insert Silence command won’t work on it, so that was one thing that was preventing me from applying that command to the whole project (i.e., I had locked tracks not viewed in a closed folder).

Is that a bug or a feature, that the folder has to be opened to be able to unlock tracks within that folder? I dunno.

  1. I could Insert Silence on all the tracks of a project only by opening a Range tool (hitting #2 on the keyboard) at the very top of the project, and dragging all the way down to have the selected range start/stop at the correct positions (adjusting in Info line as needed). This is the way I saw in an old youtube video, as kindly suggested by @Tj99 and another youtube vid he attached, and as I wrote in the OP of this thread.

In other words, setting the L/R locators to set where Insert Silence should be applied, as per the manual and kindly suggested by @Sibben above (on June 14, 2022 at 09:55 hrs) doesn’t work on my system. That seems like it would be a bug? I’d be happy to break this out (the fact that Insert Silence doesn’t work on my system by setting the right and left locators then applying the command) in a new thread if people think it’s worth it.

  1. Also noted: Multiple Track Versions on sig and tempo tracks don’t block Insert Silence from being applied (unless, presumably, they’re locked … I didn’t have any locks there, so I can’t say for sure).

  2. Finally - on my system a track being disabled does not prevent Insert Silence from being applied to it.

Geesh, what a lot of work just to apply a basic function.

Thank you everyone for your help, and any further comments would of course be much appreciated! :slight_smile:

1 Like

To be honest, I would expect the track inside the folder to be unlocked as well. However, I can get why it does not work.

Imho the solution would be to have an option to ignore when tracks /groups/etc. are locked when inserting silence and similar operations: this way you also don’t have to always unlock your tracks.
That would be a nice feature request!

Yep seems to me! I would open a support request and contact Steinberg directly, 'cause I am using Cubase on different systems for years now, and this is the first time hear about a bug like this.

Opened a feature request to move also locked tracks when inserting silence:

Option to ignore locked tracks+events when “Insert Silence” or copying, pasting, cutting ranges - Cubase - Steinberg Forums

1 Like

Have +1’d There, thanks!

It looks like things as they stand now are different on your system vs mine, based on the vids you provided there.

On yours, insert silence occurs on all tracks between the locators, except for the locked one(s)

On my system, a single locked track between the locators will prevent any tracks from moving.

How odd!