Elgato Stream Deck and Cubase 9

Hi to all,
I just just got a Elgato Stream Deck. In short, it’s a programmable usb 15 button controller, each button can be programmed to send shortcuts to whatever application you are focused on (like this present text box qqqqqq…see… i just pressed a key on the stream deck that sends “q”. Please look it up on the internet for a full description.
It works perfectly with all my applications, except Cubase (with W10)!!!
It works fine with other applications (vlc, sends correctly the hotkeys to the word pad, even the windows calculator!). So the stream deck works ok.
I have tried many configurations, cubase just does not react to the stream deck. Even when I focus on a text box of cubase (the comment textbox of the track for example), my preprogrammed hotkey “Q” has no effect. It appears just fine on other applications, and thecubase keyboard shortcuts are also working fine!
If no user has yet tried this controller, could Steinberg look into this, because I think this controller is going to be a hit and Steinberg will have quite a few issues. with it.
Thanks for all
Stéphan

Important Info I forgot … I’m running Cubase 9 as administrator. Because i’m using some 32 bit vst’s. too bad by the way that Steinberg decided not continue to recogniez 32 vst’s some are really excellent. But’s an other issue.
In normal mode, the stream deck works fine with cubase. Any idea to get around this? Thanks

How does it help to run cubase as administrator for 32 bit plugins?

This is not a midi controller, but a specially configured alpha keyboard with an ‘integrated’ macro program. So the config with Cubase is the same as any other alpha keyboard, e.g., it’s on the OS level.

As you discovered, if the permissions levels of the two programs don’t match, they won’t won’t talk to each other. So running Cubase with elevated permissions, that’s to say, as administrator, will prevent it from working.

I also don’t know what connection running 32bit VSTs has to do with running Cubase as administrator. The best thing to do is simply run Cubase as a regular user. I would presume there are other things broken in your setup due to this mismatch.

There is a version of Jbridge that doesn’t require Cubase to be run as admin. Ask the developer.

I am running jbridge that I downloaded from the website, no special request necessary, and not running as admin, Wasn’t that an earlier version of jbridge that required admin?

Edit: I see now- J offers the beta version to all owners of jbridge. That doesn’t need to run with admin permissions. It’s an automated request, though the page says it’s a beta, the file that’s delivered (as of the date of this post) is the 1.75 release.

https://jstuff.wordpress.com/jbridge/beta_updates/

Hi to all and many thanks to all your answers.
I’m using Jbridge (like steve does) to run 32bit vst’s I still use on old recordings. It works perfectly. But Jbridge requires that Cubase be executed as admin. If executed normally, then the 32bit vst’s don’t work. Strangely, everything in Cubase seems to work fine in admin mode as well as in normal mode. Never had a glitch.
But here is the answer. I never had the idea to go see jbridge if they had adressed this issue. My jbridge dates from 8 month ago, perhaps it is to old…
I’ll check it out and keep you posted. I’m sure many people will be happy to find this post.
Thanks again for sharing your experiences so rapidely.
Stephan.

yes that’s the version I’m using: Jbridge 1.75beta that I got from the same link you gave me (at the bottom left of my hypersonic 2 vst window it clearly says “Jbridge 1.75” so there is no possiblity of a wrong version on my part. I’m a registered user of Jbridge so there is no possibility of a illegit bad copy either.

I have noticed in the fixes that had been addressed from 1.74; it says “– Disabled the “run as admin” warning for better compatibility with Cubase 9.” It says it disabled the warning, not the fact that you can run without admin mode. I don’t know if that makes a difference.

Hypersonic 2 works fine in admin mode, in normal mode it shows a hypersonic blank window. Of course the instruments are not accessible since they don’t even appear in the window.

Can you confirm that you are using Windows 10, Jbridge with Cubase 9 in normal mode and that all your 32 bit vst’s work? If so, something is very strange.

To complete the whole story: The problem is not only with the Stream Deck, I was using the ShuttleXpress to control the transport in cubase SX on WXP.
When I went to Cubase 9 with jbrdge on W10 on a new machine last august, the ShuttleXpress wouldn’t work in admin mode. I had contacted the support from Shuttle Xpress, they said they would look into it, recalled them again 2 months , same answer. Nothing since. Not surprising considering your explanation about how admin mode works: Any controller other than a midi controller will have that same problem. I"'m using QconPro controller, works just fine in normal and admin mode. Makes sense now, it is a midi controller.

Follwing grim’s advice, I’m going to contact jbridge developers and ask about a version that does not require admin mode. I’ll keep you posted of course.
If anyone has an idea in the meantime…

hi again,
sent a mail to Jbridge… good and fast communication answered within 2 hours.
There is in fact a 1.75 version (not the 1.75beta I had installed). The beta does not works properly.
Jbridge sent me the 1.75 version, and voila! everything works… at least for the moment, we shall see in time.
The main page of jbridge lets you think that 1.75beta is the latest. When you go the jbridge update page, the latest version is 1.74!!! So, not knowing that there is in fact a 1.75(not beta), difficult to ask for it. I’m not even sure it’s on their site yet. Ok they are better developpers than they are into site management. The fact that they answer their legit clients almost instantly makes them greatly forgivable!
Good program this jbridge, fixes a need Steinberg does not seem to spend time on…
Thanks to Steve and Grim for telling me that there is a version that works with out admin mode.

:smiley:

After 24h of of configuring It’s a good product but it seems to have some little bugs: for example when creating a hotkey, it recognizes the up-arrow and the down-arrow key form the keyboard to go up or down one track on the cubase main screen. It says “Up” on the stream deck screen meaning it did infact recognized the up-arrow key, but when trying it out on cubase, cubase does not respond. Apart from all seems ok.
After 24h of configuring and use it’s a god product although it was not meant to be a daw controller, but it does the job fine.
As with all computer products it takes a bit of tinckring to get what you want.

What’s the score with the virtual icons…can you make your own graphics to match the functions or are you stuck with icon graphics they provide?

You can make your own Icons.
There are some program focus issues, and you can only run one atm.
There are a bunch of Youtube reviews that cover most of it.

Word is multiple decks are now supported, anyone test drive those with Cubase? The single one I use so far is truly the bees knees for many different applications, DAW or other

I got the same problem, WIN 10 64 Cubase 9.5 64bit, jbridge 1.75 (+Elgato Stream deck) Some Shortcuts working, others like up, down, left, right dont. In other apps these functions working fine from stream deck, in Cubase they dont.
I would need help, is there a workaround to make this functions running in Cubase?
Thanks for your suggestions.

Jens

Old thread, but I’m thinking on Mac OSX you might have to add the app to the privacy accessability app list.
With the Slate Raven touchscreen and it’s various UPDD/other software you have to do this, this may the case with the Stream Deck as well.
Open system preferences/security and privacy/privacy and add the Stream mate app/apps to the list, and see if that helps.

Best

  • BT

Hey Stef, sorry to revive an old thread, i just bought an Elgato for other programs, but i am a Cubase User.
Any tips on how to get it mapped for transport control and other functions in Cubase?
Using Cubase Pro 10 on Windows 10.

Cheers,
Rexx.

Same here, would love to have Cubase working with stream deck

Same here, would love to have Cubase working with stream deck

My Cubase Stream Deck plugin is available in the Stream Deck store, just install it and play with it :smiley:

Helped me. +1 Thanks