eLicense Control Center, download latest version

When I enter the activation code I received for Cubase 11, I receive the following notice:

The currently installed version of the eLicenser Control (eLC) software is too old.

Please try again after downloading and installing the latest version of the eLicenser Control software from <> www.eLicenser.net> >.

Yet I have the absolute latest version that was released today, 6.12.5.1278. I even tried uninstalling and re-installing, but nothing changed. What do I do?


EDIT: Apparently the download manager is responsible for this. Now I get the error dre-417 .

I am on macOS 10.15, latest version.

Same here.

Same here…

Oh, the same issue here: https://www.steinberg.net/forums/viewtopic.php?f=310&t=202169

Wow I remember downloading Cubase 10 on day 1 just fine.

Me too. The format of the license numbers differs from the layout in the license control centre. I note from my order confirmation :-

Cubase Pro 11 Update from Cubase Pro 10.5

macOS 10.14, macOS 10.15
but I am on Windows 10. Do you think I have the wrong code.

Me too. Bah.

The Download Access Code is not an Activation Code, so stop tryign to use eLCC to Activate using that.

You input that into the Download Assistant, which Generates an Activation Code that is fed to eLCC to Activate your product.

The server used to generate those codes seems to be offline.

eLCC is non-factor, as far as this issue is concerned, as you’re inputting the code into the wrong application.

I am not sure why people are still trying to do this…

When I do this…I get the error-code “Dre-417”

Any ideas what this means?

Dre-417 anyone?

Trensharo - the problem is that even when following the correct procedure (using the Download Code as required) the eLCC process fails as the relevant server(s) have failed. At least that is the experience for most of us. It is almost as if Steinberg has been hit by a DNS raid.

Seems to have been repaired - just u[graded two licenses.

Nope. It most definitely has not been repaired. I’m still getting the same error messages and tried all of the suggested methods of activation.

Same here…

Losing hope…

Likewise still getting the dre=417 error… frustrating!