eLicense dongle works in Win10 but not OS X.

I’m running a new MacBook Pro. Running Win10 in parallels, the eLicenser works perfectly, all licenses appear as they should (I have 3 of them).

But running in Mac OS X, the eLicenser dongle blinks as it should, but the software pops up a box that says:
eLicenser Control - Error
Application ‘LCC2’ has caused the following error:
Connection to protection device lost.

There are buttons for cancel and retry. Retry results in a few seconds of new blinking and then the same message again.

This all happens even if I run Mac OS straight, never launching Parallels at all. And if I do launch Parallels, I’ve ensured the licenser hardware is allocated to Mac, not Windows when I’m doing this. (And I allocate it to Win10 when I test there, and then it works perfectly.)

For both WIndows and Mac, the hardware is in the same USB port, a direct port right on the laptop itself.

I have uninstalled and re-installed the latest eLicense program twice.

I’d prefer to run on the Mac OS. How can I resolve this?!?

Thanks!
Jim

Hi,

Isn’t the USB-eLicenser connected to the Windows 10 via Parallels at the time? I don’t know your setup, and I don’t know if you try to Acces the USB-eLicenser from Windows and Mac OS X at the same time. Do you?

Hi Martin. This is what i mean by “allocation” to Windows or MacOS. It is correctly assigned for the system being used. And when parallels is not running at all, this is not possibly an issue – all hardware is used only by the Mac OS.

Hi,

Can you see the USB eLicenser as an USB device in the System Information utility?

I am new to the Mac OS, so I don’t know about the System Information utility. In a few hours I’ll be back at the machine and will investigate this. Thanks!

Hi,

Just search for it in the Spotlight (Cmd+Space bar). :wink:

Here’s a screenshot showing that the Mac OS does see the “Protected Executer” device:
https://www.dropbox.com/s/s50wef5ydo3q875/Screenshot%202016-07-13%2023.00.56.png?dl=0

Protected Executer:
Product ID: 0x0101
Vendor ID: 0x0819
Version: 1.01
Speed: Up to 12 Mb/sec
Manufacturer: Syncrosoft
Location ID: 0x14100000 / 9
Current Available (mA): 1000
Current Required (mA): 16
Extra Operating Current (mA): 0

Jim

Hi,

Try to connect it to any other USB port. The one you are using is USB3, all others are USB 2.0. Some older USB-eLicensers are not USB3 compatible.

And you really don’t need USB3 speed for license check. Might be you use the speed for other tasks.

Are you by any chance using a tool called “duet” that connects your iOS device(s) with your Mac?

Duet causes an incompatibility, the symptoms are exactly what you are experiencing:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/mac-recognition-issues-of-usb-elicensers-on-el-capitan.html

I think I may have that installed – to use my iPad as a second monitor. I’ll remove it and see what happens, but I won’t be able to until Saturday. Many thanks!

Unfortunately, still no luck. It was not Duet that I had installed. I’ve removed the other thing that is similar. I also removed a NTFS driver (for using Win-formatted external HDs) because it looked like it might get in the way of other USB devices. No different with that, either.

Once again, if I boot into Win10, it works perfectly on any USB port. Thus, all the hardware is good, every single piece from Dongle to USB port to system.

I really wish I could get it working in the Mac OS. And once again, when I’m using Mac OS, the Win10 system is NOT running. This is not a collision or contention thing.

Some thoughts:

The eLicenser device showing up in System Profiler means that the operating system is aware of the device; it doesn’t necessarily mean that it’s available to the eLicenser driver installed on that system.
For example, when you’re connecting your eLicenser to a running virtual machine, both the host system’s and the guest system’s System Profilers will show the eLicenser USB device. Still, only one of these system’s eLicenser drivers will be able to utilize the device.

Anyway, it was a good idea of you to try to deactivate all software components that might interfere with the eLicenser USB device; I suggest to go one step further and boot your Mac up in “safe mode”, to definitively deactivate any 3rd-party driver, Startup item etc. that might interfere:
http://www.idownloadblog.com/2015/07/29/how-to-boot-mac-safe-mode/


Another thing to recommend would be checking the system logs for any related error messages.
I’m always using “Console” utility for this purpose.

In Safe Mode, nothing has changed! I just can’t believe it. And it’s very annoying. :frowning:

Licenser opens, starts looking for the dongle.
The dongle starts blinking, there is obviously communication.
Screen Shot 2016-07-27 at 4.13.54 PM.png
Then the same old error message pops up:
Screen Shot 2016-07-27 at 4.13.41 PM.png
Jim

Are there any indications in the system logs regarding the device’s inaccessibility?

I used Console to view system.log.
Closed all other programs including browser, email, etc.
Removed all USB devices.
Cleared the Console display screen.
Inserted the dongle.
Ran eLicenser, clicked through error screens with Cancel buttons.
Closed eLicenser.
Removed the dongle.

From the moment I cleared the screen through to removing the dongle, this is what appeared in the log:

Marker - Jul 28, 2016, 9:29:14 AM
Jul 28 09:29:27 JDS-MAC WindowServer[157]: send_datagram_available_ping: pid 249 failed to act on a ping it dequeued before timing out.
Jul 28 09:29:31 JDS-MAC loginwindow[103]: -[SFLListManager(ServiceReplyProtocol) notifyChanges:toListWithIdentifier:] Notified of item changes to list with identifier com.apple.LSSharedFileList.RecentApplications
Jul 28 09:29:33 JDS-MAC License Control Center[1581]: ApplePersistenceIgnoreState: Existing state will not be touched. New state will be written to /var/folders/cd/jzq_8zjs0gx_wrz82l89dvf80000gn/T/com.Syncrosoft.LCC.savedState
Jul 28 09:29:34 JDS-MAC WindowServer[157]: disable_update_timeout: UI updates were forcibly disabled by application “eLicenser Control Center” for over 1.00 seconds. Server has re-enabled them.
Jul 28 09:29:35 JDS-MAC kernel[0]: IGAccelDevice: IOUserClient outputCount count mismatch
Jul 28 09:29:35 JDS-MAC WindowServer[157]: common_reenable_update: UI updates were finally reenabled by application “eLicenser Control Center” after 1.77 seconds [0.56fps] (server forcibly re-enabled them after 1.00 seconds [1.00fps])
Jul 28 09:29:46 JDS-MAC WindowServer[157]: send_datagram_available_ping: pid 249 failed to act on a ping it dequeued before timing out.
Jul 28 09:30:25 — last message repeated 2 times —
Jul 28 09:30:25 JDS-MAC syslogd[47]: ASL Sender Statistics
Jul 28 09:30:29 JDS-MAC WindowServer[157]: send_datagram_available_ping: pid 249 failed to act on a ping it dequeued before timing out.

Is any of this any help?

Jim

Hey Dirk – I appreciate your help so far, and I realize this is a tough one. I really hope to get to the bottom of the problem, so I can use Cubase and Halion on this machine. I have a considerable investment in Steinberg, so I really need to get this figured out.

Many thanks,
Jim

You say that you have re-installed the eLicenser, but have you downloaded a fresh copy? I have run into the eLicenser software acting up on several occasions, with re-installing from the installer I have making no difference. The solution has always been the same. 1) Remove the current installation (using the eLC-Uninstaller). 2) Download a fresh copy ( http://www.steinberg.net/en/company/technologies/elicenser.html ), even if it’s the same version number you’ve got, and install this.

This is weird, that a new installer with the the same versions number as an older, should work when the older doesn’t!?! But that’s been the case with the eLicencer installer for many years.

I had high hopes for this. Alas, no change. Used the uninstall utility. Downloaded again. Installed fresh. Still doesn’t work. Tried both USB ports (there are only 2 on this laptop).

The program recognizes the initial insertion of the dongle. Wheels are spinning. Then the dreaded box pops up about “Lost connection” as detailed above.

Sigh.

Just use the Windows version. It runs better anyway, like most other programs.

I would agree with you… except that this is a Mac. Windows is running in Parallels, with limited resources and a layer of abstraction (Mac OS) between the system and the hardware. Using eLicensor in Windows proves that all the hardware works, but it’s not a great solution, in my case, for actually doing any production music/sound work.

This problem has arisen because I’m retiring my old PC (which is now old and slow compared to new boxes) and now have a new deck-out MacBook Pro. All my software discs include Mac versions. I want to run on Mac. And it’s supposed to be able to.

I do feel that I paid for the ability to use all this stuff on a Mac. :slight_smile:

Jim