elicense offline

Today, this morning I started Dorico with no problem. Early this afternoon, in a place with no internet access, when I tried to start Dorico I got the “No Valid License” screen. Not having any internet, I was completely unable to do any work. Later this afternoon, back with internet access, Dorico started fine. SOMETHING IS WRONG!, This is hugely frustrating and costing me a lot of time and effort. While I love Dorico, I HATE, HATE, HATE this obnoxious licensing scheme which more that 10 times in the past few months has denied me the ability to use software to which I own a valid license. I consider this unconscionable. PLEASE FIX THIS NOW! MAKE THIS YOUR TOP PRIORITY!

Steinberg software never requires an internet connection once activated.

Try installing the latest eLicenser Control Center and running Maintenance Tasks:

That’s true, only the activation of a new license code or the maintenance tasks needs an internet connection.
Please run the maintenance task, hopefully that will fix your issue once for all.

Ulf, How am I supposed to run maintenance when I am offline? When the license doesn’t work when it is supposed to I am totally screwed. Telling me that it doesn’t require a license when offline doesn’t help when clearly it did not work today! To reiterate, Dorico opened fine today while online and while offline all I could get was the “No Valid License” screen with no way to run maintenance. BTW, I have run maintenance about 3 times in the past month and yet I still keep getting this damn message. I am really sick of this.

What we’re telling you is to just download the eLicenser Control Center and run Maintenance Tasks once, while you’re online. If you get the error message while offline, of course trying to run Maintenance wont fix it.

Try what I suggested in my first post. Does it still happen when you go offline? Do you have the latest version of Dorico installed?

I will run maintenance AGAIN, but here is some history:

About 2 weeks ago after a windows update I had to reinstall eLicenser Control Center and get new licenses. Problem fixed.
About 3 days ago I got the obnoxious No Valid License screen while online and ran maintenance. - Problem fixed.
Today, after working fine in the morning, I got the message AGAIN.
Later while online the problem went away.

I have been using (and very occasionally writing) various software packages for over 50 years and in that time I have NEVER encountered a more unstable or less robust license mechanism. No program before this (with costs ranging from $0.00 to $70,000.00) ever had need of a maintenance button or repeated downloads just to allow me to run it. From my experience and in my not so humble opinion, the soft eLicenser is a piece of excrement that should be destroyed and replaced with something stable, robust, and user friendly.

And, yes, I have the latest version of Dorico.

Damn, Damn, Damn! I ran Maintenance and it failed and now I have a deactivated soft eLicenser. Damn, Damn, Damn!

I tried maintenance again with the same result. I then went to MySteinberg to Reactivate and my new soft eLicenser was not listed. I entered the new number (twice because somehow it didn’t like it the first time), got it registered and then FINALLY maintenance worked. While it now appears to be fixed (I’ll try offline again tomorrow) this should never have happened.

Let me be very clear: I love Dorico. I think it is an amazing program and expect it to become even better over the next few years. But, I will not recommend it nor will I spend another cent with Steinberg unless and until Steinberg gives us decent licenser to go with its great software. If the licenser ever does get replaced with something good, I will be one of your most vocal advocates.

This is the first time hearing about someone having an issue like this, and I’ve been using Steinberg stuff for years. Sorry that you ran into issues but I’m pretty sure that this was caused by something in your computer getting in the way of the activation process, not an issue with the eLicenser system itself, which most have been able to use without issues.

If this happens again I recommend contacting support directly through your MySteinberg, they should be able to help you figure out what’s going on. There might be a chance that this is either the result of using overzealous antivirus/security software or an actual virus infection. It might be worth investigating.

I’m really sorry to hear you had all of these problems, Bob. I routinely run Dorico completely offline when I’m on my way to and from work on the train, and I have never had this problem, and knowing a little bit about how the eLicenser system works I am surprised to hear that you would run into this problem at all. I believe it must somehow be related to the issues that cause the Soft-eLicenser to become deactivated after big Windows updates for some users, and which are normally resolved by running eLCC as administrator and allowing it to perform its maintenance task. I will definitely bring your experience to the attention of our eLicenser team and ask if they have any ideas what might be going wrong on your particular computer.

We are of course always evaluating improvements or changes we could make to our licensing technology that balance the needs of the business with the convenience of our paying users. I am hopeful that in the medium term these sorts of issues will be a thing of the past.

Hi Daniel,

Can you say if we are getting any positive feedback from “on high” regarding any lessening of the strict Steinberg e-Licenser policy as it stands today D due to the nature of the Dorico user’s experience and need? (I think that most users would agree that the overall working relationship of user and software is quite different from the rest of Steinberg fleet.)

Hello batwell,

from what you’re describing, it is possible that you’re experiencing these issues due to a design restriction of the eLicenser Control software.

The restriction being that every copy-protected program that utilizes the eLicensers (e.g. Dorico, eLicenser Control Center, Cubase etc.) must be run as non-administrator.
Or, alternatively (but I do not recommend this), all copy-protected programs must be run “as administrator”.

If you start some programs as administrator (e.g. eLicenser Control Center, for maintenance issues), and simultaneously start other programs as non-administrator (e.g. Dorico), this will cause conflicts in the eLicenser Control runtime, because both administrator-level and non-administrator-level programs are competing for the eLicenser drivers.

So, if you ever need to run a copy-protected program (like Dorico, eLicenser Control Center, etc.) “as Administrator” to solve a specific problem, please do so, but please ensure to quit that program as soon as the problem is solved.
Do not run programs like Dorico, eLicenser Control Center, etc. in different run modes at the same time.

Hope this helps.


Thanks Dirk, That may explain the issues I have been having. But, it seems that Windows 10 1709 really wants me to run Dorico as administrator. Currently I have set up both Dorico and eLCC to always run as administrator. You say you do not recommend this, why not?

Dorico should not need you to run as administrator. What error message are you getting that suggests that you do?

The problem that I have been having is that on a WAY to regular basis, when I start Dorico, I get the “No Valid License” screen. On my old computer and prior to the Windows update, just restarting Dorico usually fixed the problem. With my new computer and after the Windows 10 Fall Creators Update, it still happens a lot and it seems that I always have to get a fresh eLCC, register the eLCC, get license codes and download the licenses to get running again. I have never yet gotten the “No Valid License” message when I run Dorico as administrator. Maybe I don’t need to run as administrator but right now I am on a tight schedule and I am so paranoid about the eLCC dying AGAIN that I will do whatever I think will keep me up and running.

Areas of curiosity:

What is the make and model of the computer you’re using? What is the available RAM?
What antivirus and firewall are you using?
Are you using a VPN? If so, is it Microsoft’s or a third party?
Any unusual devices or device drivers installed?
Have you seen any pattern involving the use of any of the ports on the laptop? (esp. USB, Ethernet, video)
Any other admin privileged programs running routinely?
Any virtual machines running on the laptop (whether or not Dorico is running)?
Any special “Disk Cleanup” or compaction software running?
Any remote USB mounting software running?

Just hunting around for clues. The last time I saw something like this, it was tracked down to an eSATA port (this was about 10 years ago when eSATA was a thing) and it was another licensing system.

I’m currently running the same OS as you on a Microsoft Surface Book and other than repairing the license once after after the update, I have not seen this behavior.

What is the make and model of the computer you’re using? What is the available RAM? - - - Lenovo Flex 5, Intel i7, 16G RAM
What antivirus and firewall are you using? - - - VIPRE
Are you using a VPN? If so, is it Microsoft’s or a third party? - - - NO
Any unusual devices or device drivers installed? - - - NO
Have you seen any pattern involving the use of any of the ports on the laptop? (esp. USB, Ethernet, video) - - - NO
Any other admin privileged programs running routinely? - - - NO
Any virtual machines running on the laptop (whether or not Dorico is running)? - - - NO
Any special “Disk Cleanup” or compaction software running? - - - NO
Any remote USB mounting software running? - - - NO

Honestly, at this point I think the problem is probably solved.
But, until I get my current project finished I am unwilling to try any further investigation or make any changes to my system.

Update on the continuing saga of my license problems:

This morning I started up my computer, started up Chrome and watched the latest Discover Dorico, started up Dorico (as administrator) which ran fine . As far as I know these were the only 2 foreground processes running. After a couple of hours work I closed both programs and closed the lid on the laptop. About 30 minutes later I opened the computer, logged in, and tried to start Dorico. Got the No Valid License screen. Restarted the computer and tried Dorico again with the same result. Did a hard reboot and tried again. Dorico started fine but also started the “Tour” as if I were a new user. Note that I never ran eLCC in this process.

Why does Dorico continue to lose track of my license. Why do I keep getting told I have no valid license when I do? Why didn’t restarting my computer fix this? Why did a hard reboot fix this?

I still believe that the eLCC is a piece of garbage and needs to be replaced.

One area of experimentation I could recommend is to try a different antivirus or just run WIn10’s Defender and Firewall for a without VIPRE to see if this changes anything. Based on what you described (Dorico restarting with the Tour) suggests some change happened to the disk in your user.

The second are of experimentation would be to temporarily create a new user on the computer and see if the behavior happens on that user as well your current one.

The third area that came to mind is that if you’re using OneDrive’s “Files on Demand” feature, turn this off for a while and see if this eliminates the behavior.

But if run program “as administrator”, the program can’t do things like dragging files into it.