Elicenser is not showing up

Hi there,

I have a strange problem. I can see nothing in my software elicenser which I have downloaded 3 minutes ago from its original website. I can’t see any buttons, text etc so I can’t register my products with it. I have posted a screenshot of my elicenser window where you can see there is nothing as a text so I don’t know where to enter codes, licenses etc. I have bought UR44 Audio Interface last year and elicenser which came with it had same problem. I barely registered cubase ai and basic fx süite with it. But today with a new PC it has same problem again and I don’t really remember where I had posted my licenses before. Also another friend of mine bought same audio interface with my suggestion last month. He says he can’t see its text too. So both of us have same problem so we can’t register our products. If anyone has any explanation or solution for this we would be very appreciated. Thanks in advance.
screenshot.jpg

Anyone?

Hello morphsynth,

you might be encountering a rare issue that occurs on Windows systems that are set to either “Turkish” or “Azeri” language.

If this is the case, you might want to change your preferred language to one of the officially supported languages (e.g. English) before launching eLicenser Control Center.

Best,
Dirk

Hi,

Thanks for the reply. Yes, I am from Turkey, my Windows language is set to Turkish naturally. When I change my windows language to English my problem seemed to be solved. Though let me suggest you something, this language problem should be solved. I mean I always use Turkish Windows and the very first software I have ever got problem with is eLCC and it is not very convenient for me as a customer. Me using Turkish as my windows language shouldn’t mean that eLCC should turn its language to Turkish from English and show nothing. I am not awaiting a language support as my country don’t use these products so much as other countries but at least software shouldn’t prevent me from doing a simple process as seeing it in English :slight_smile: I can use all other music softwares which don’t have language support in English in my Turkish Windows and don’t have any problem with them. So please forward our complaint about this subject to relevant sections of your company. Other than this problem I love all Yamaha and Steinberg products always. Thanks again for the fast help :slight_smile:

Best,
Gökhan Damgacı

That’s great to know, thanks for your feedback!

So please forward our complaint about this subject to relevant sections of your company.

Done.

Again, thanks for your feedback.

Best,
Dirk

Hello, I have the same problem. Yes, I am from Turkey and my situation is more complex. Because Windows 10 do not let me to change the language. It is not allowed to change it. Yesterday I purchased MP3 package but cannot install without seeing the letters in the elicense panel. Ok than what will I do???

Hello,
Exactly the same problem;
https://www.steinberg.net/forums/viewtopic.php?f=226&t=102891
I am running a single language pack of Windows 10 and I want to activate my purchases, such as the Cubase Elements I purchased yesterday.
Regards,
Alphan

Same problem here and it is around for quite a while now. Windows 10 is set for Turkish and I cannot change it. I am having issues with my license and I am not even sure what the problem is.