Elicenser not recognized in Mojave

Hey SRN2016, we have very similar macs and for me the problems seem to be finally gone. I did all sorts of troubleshooting on and off for several weeks, but some of the last things I did which coincided with the problems disappearing were

  • rebuilding preferences of all Steinberg software
  • rebuilding the soft e-licenser by using a special ELC installer available from Steinberg (I was not using the soft ELC however)
  • Replacing the PRAM battery, which I probably should have done earlier anyway. This was because I found various posts suggesting a dying battery could affect low level functionality like USB so I thought why not.

For the last week I have had no issues, while before I would get ELC connection losses every 20 minutes or so when using any Steinberg software. I also bought a Sonnet USB 3 card and a new dongle and those work perfectly, but my problems disappeared before I got them.

Otherwise very happy with the performance of Mojave in general and Cubase 10 on my machine.

Hi MrFluga, thanks for your post and all the info, interesting, I will try and respond to each of your points:

  • Preferences: I did these when I first started getting the problem with Cubase 9.5, have done it again with Cubase 10.0.10, seems to make no difference.
  • Soft elicenser? I am not sure what you mean by the special installer? I have just the latest eLicenser downloaded from Steinberg 2.8.2.0 install version 6.11.3.1244
  • PRAM battery: I replaced this just before I installed Mojave in November when I put the new graphics card in.
  • Sonnet USB 3 card: I have had one of these installed for since 2017 but I am using the dongle on one of the builtin USB 2 sockets. I am pretty sure I have tried it in one of the USB 3 sockets and got the same issue but I will try again to make sure.
  • New Dongle: I am using the dongle I got when I bought Wavelab 9 in Sept 2016.

I have not experienced any ELC connection loss once Cubase is up and running, which is often for hours, sometimes all day 10-12 hours. It is only when opening Cubase (I have not used Wavelab for a while, so I will only talk about my experience with Cubase) that I get the issue. As in my post above if I launch the eLicenser app then close it before opening Cubase it opens normally, however Cubase must be opened straight away, if I wait 5-10mins then open Cubase the connection loss happens.

Also just in the past couple of days, sometimes before the eLicenser opens I now the the message that the eLicenser app needs to be upgraded to be compatible with Mojave, I had not had that before, then the eLicenser open normally.

I totally agree about the performance of Mojave in general and Cubase 10, both are running superbly. Mojave is undoubtably the smoothest quickest responding macOS I have had on this machine in ages if not ever and Cubase 10, other than this ELC issue and one other issue related to a 3rd party plugin is performing superbly, much better than 9.5, the CPU usage seems way better.

It can be found here:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/soft-elicenser-is-missing.html

I think it just deletes the soft licenser and creates a new one along with installing the regular ELC. But I have no idea if it played some part in solving my issues.

Thanks for that, I’ll let you know how I get on.

I downloaded the installer but I thought first off I would try moving the dongle from one of the builtin USB 2 sockets to one of the USB 3 sockets on my Sonnet USB 3 card, that was on Tuesday 22nd and as of today (Sunday 27th) every time I have launched Cubase 10 it has opened with no error! Every so often I do get the ‘eLicenser needs to be upgraded to be compatible with Mojave’ message but then it opens normally.

I’m not going to install the soft licenser special installer.

It is also worth noting that the USB 2 socket the dongle was in was the same one it has been in since I got it and worked fine with Sierra.

If anyone can make sense of this I would be interested:-)

That´s great, also as far as I understand the release notes the recent update of the ELC should have no more 32 bit issues with MacOs.