eLicenser not working

Hello.

I just reinstalled windows 10 - 64 bit and got to installing cubase 8.5.

During Cubase installation eLicenser installation gives this error multiple times:

“Microsoft Visual C++ Runtime library
Runtime error!
Program c:\Program Files (x86)\POS\SYNSOPOS.exe
This application has requested the Runtime to terminate it in an unusual way.”

I click OK on it and the Cubase installation carries on and gives the same error again after each part of cubase has installed (halion SE / drum libraries etc etc).

After the Cubase installation I remove elicenser via control panel, check that all it’s folders are empty, download the latest elicenser version and try to install it, but the same error comes again.

Well, I click OK on it and it seems like the elicenser should be installed even though it gave the error. I start it and get this error:

“Unknown Exception caught. Process execution failed”

The elicenser starts after that but will not scan for any dongles or allow me to do anything else but exit or view help.

I try to reinstall elicenser - no help
I try to run it as admin - no help
I even try to reinstall cubase (by downloading the whole 8.5 package again just to be sure) - no help
I run repair to all microsoft visual C++ packages that allow it - no help
I remove elicenser and check all it’s folders and follow the steinberg instructions to manually check that it’s all gone and reinstall the latest version - no help
I try to install and use elicenser with dongle attached to PC and not attached - no help
I quit every program and even turn off antivirus during installation - no help

I’m running out of ideas what to do here. Never had this kind of issue.

Can anyone help me on this? it’s been weeks that I havent been able to use Cubase, Steinberg is not answering to my support request. I could try reinstalling windows but dont really wanna go through it without knowing for sure that it will help.

I Uninstalled every c++ component witout reinstalling them on windows and still got the same error. For me that seems like the c++ library included in elicenser package has some compatibility issues with the latest updates of Windows 10.

That must be so frustrating.

I don’t have any problems on my desktop (10 pro) or laptop (10 home) running Windows 10 x64, but I have noticed something over the last several weeks with my desktop (Windows 10 pro) when I run do the Microsoft ‘Check for Updates’ routine. I get a message that the machine is downloading and then installing ‘Microsoft C++ 2012 Update 4 Re-distributable’, but it does so three or four times before I finally get the message my machine is up to date. If I was guessing, I’d say it looks like it keeps on trying to download and install this, but fails to do so. This message regularly appears when I check for updates, but it hasn’t caused any problems with Cubase so I haven’t paid too much attention to it. Thinking about it now, this repeating download/install message may happen every time I check for updates.

I appreciate this may be of zero help to you, but your post reminded me of the unusual downloading/installing activity on my machine that relates to the above C++ package. Have you performed maintenance on your eLicencer? Unplugged it and changed the usb port? Do you know anyone who has a Steinberg dongle that you can try on your system? I hope you find a solution soon.

Steve.

You said you tried running elicenser as admin but have you tried running the elicenser installer as admin?

Hi

Thanks for your ideas. It doesnt even matter if the dongle is attached to PC or not, elicenser gives the error either way. So the problem is clearly not with the dongle itself. Can’t run maintanence on elicenser as the software only allows to exit or view help. And I’ve tried installing the elicenser with admin privileges.

Issue solved by reinstalling windows 10 and installing elicenser 1st after the boot before downloading any windows updates.

No Idea of the cause, guess some update with Visual C++ 2005 in Windows 10 messed up the compatibility with the latest version of elicenser.

Btw, still no answer from Steinberg after 25 days from ticket. Their support seems really slow nowadays.

Inrot, don’t know if this will help,but here goes: make sure that you disable( temp. ) any anti-virus programs you have running ( like AVG for example); also lower your security settings down to a minimum ( temp. ) It worked for me after fighting it for 2 weeks. One more thing, make sure they send you the proper activation license number. They sent me a USB e-license instead of a soft e-license no. Also, don’t forget to reset your settings to normal. good luck…gerbla

Thanks for this post. I am having simular issues with Windows 10 and Cubase 8.5.15 after upgrading the elicenser software. Also getting synsopos.exe and dcom errors. Not looking forward to reinstalling Windows and starting over. Does anyone have any other suggestions? Would Windows 7 Pro be an advantage over Windows 10 Pro if a reinstall is necessary?
Inrot, did you ever hear from Steinberg?

As said Install the eLicenser as admin.

Thanks Peakae, had the same issue after uninstalling and reinstalling the elicenser as administrator. Updated Cubase to 8.5.20 and it seems that it may have resolved it.

The first thing you should always to when the eLicencer don’t wanna play ball (before changing any settings) is to download the latest version and install it. This has helped for me even when I did have the latest version installed.
http://www.steinberg.net/en/company/technologies/elicenser.html

If that doesn’t work; start “hacking”.