eLicenser weird issue ( keeps telling me I don't have the latest version )

So I try to enter a new activation code and eLicenser tells me I need to install the latest version.
I download it, install it, and…eLicenser STILL tells me I need to install the latest version :open_mouth:

As you can see on the screen, I do have the last one (
I’ve tried opening it with administrator privileges, tried every option possible within eLicenser ( clean database, memory…) and I’m now running out of ideas !
It’s getting quite frustrating…


Could you try to start eLCC as Administrator? Also make sure you are installing it as Administrator (so uninstall/re-instrall).

Hey Martin,

Just tried exactly that, still getting that same message :confused:

Make sure, you are entering an Activation Code, not Download Access Code, please.

Oh wow that was indeed the issue…
The code I had was marked as “Activation Code” while it was indeed just a “Download Access Code” !
Can’t thank you enough for this Martin !!
Now I’ll go and enjoy the wonders of Cubase 10 :slight_smile: