eLicenser wonky on Win10 for me.

I recently moved from Mac to Windows and have had constant issues with my eLicenser, which I never had on Mac. Sometimes eLicenser sees nothing on the USB key, or sometimes it will stop seeing it in the middle of a session. I bought a brand new eLicenser key because I thought the former one was damaged, but am having the same issues. I also tried uninstalling and reinstalling the eLicenser software, which didn’t fix the problem.

Can anyone advise?

Just trying to help… Try this link. I always keep this usb selective suspend option disabled. Hope it is usefull for you

https://www.windowscentral.com/how-prevent-windows-10-turning-usb-devices

Thank you. That was already disabled, but my computer builder recommended using a USB hub. I tried that (had one laying around) and so far it’s been good. He said something about the voltage with hubs vs. the computer. It’s a drag to have to do that vs. Mac where I never had an issue…but c’est la vie.

Well damn, it’s happening again. Anyone have other ideas?

Just a thought - is your usb hub a powered one? I had problems with the elicenser on my MacBook Pro (reading my Cubase pro licence as Cubase Artist; disconnecting randomly; saying licences were missing) which have (touch wood) all gone away with moving the dongle to a different port. I suspect my Caldigit hub was struggling to power all my use devices.

Steve

Hey In_Stereo,

This is long shot, but in Windows 10 go to Device manager. If you scroll down to Universal Serial bus Controllers. Expand it and it should say
Generic USB HUB or something close to that. If you right click each one except USB Composite Device and go to: Power Management tab,

Uncheck: Allow the computer to turn off this device to save power.

Hope this help.