Elicenser wont connect to the server

Hi,

I bought the Focusrite Scarlett Studio bundle 3 days ago and have been struggling to get the Cubase up and running until now. I followed the video instructions exactly as outlined on the focusrite page.

First problem - I downloaded the Cubase setup file and installed it. However when I went on to activate my code I found out that the elicenser had not installed (this was supposed to be done automatically as part of running the cubase setup). So I looked up the steinberg help and manually downloaded the elicenser.

Next problem, the soft elicenser wont appear in the elicenser. I again looked up steinberg forums and support and downloaded and installed the “elicenser helper”, which fixed this problem.

Next problem, now I enter the activation code in the elicenser and hit continue then download license but I get this error saying the elicenser cant connect to the server and either there is a network error or the server is unavailable due to maintenance. (Screenshot of the error attached herewith)

I again checked the steinberg forums and tried the following recommended fixes:

  1. Install latest elicenser, which apparently fixes “most” network issues - Didnt work
  2. Turn off antivirus and firewall - Didnt work
  3. Synchronize system clock with the internet time - Didnt work

Please help me with this…please!!
Error.jpg

Can someone please help me with this? Its very frustrating to have the software and the hardware but not being able to use it because of a stupid little software bug.

Please use eLCC’s “Create Support File” function from eLCC’s “Support” menu, then contact Steinberg support and send them this support file. The support file should contain vital information about what’s going wrong.

Best,
Dirk

My Elicenser control center wont connect to server either.
Not during the maintance updates or when trying to activate a code. Itll get to the final stage to send information and then says error. I have emailed steinberg numerous times and no ones giving me any help.
Ive tried about all possible solutions too. Tried both old and newer versions of elicenser. Ive fixed the firewalls and synchronized time.
I need help, been dealing with this for almost a week.

My Elicenser control center wont connect to server either.
i dont know what to do

good… i just updated the Elicenser and it worked perctly…thanks…

A post was merged into an existing topic: eLicenser Server Status

I guess I am gonna just remove it… it’s like a bloatware atm