Hi guys,

I just plopped to upgrade to Cubase 7…& already Im having kittens with MAJOR problems!

After having NEVER had an Elicensor issue,since its inception…I now after having tried 3 seperate computers to activate my cubase 7 license, is unable to update to Cubase 7!!

The Elicensor app crashes at the same point on ALL the seperate computers. The elicensor app, seems to install ok, (I am using the LASTEST version 6.5.4 .1120 and I can enter my Cubase Serial…It recognises the Serial as one for Cubase 7. Then when I tell it to download the license…It simply stops working about 15% into the download.

PLEASE if anyone has any info as to what could be the problem OR a solution Im all ears!.

If anyone from Support is reading could you help a brother out! :wink:

Run as Admin? Firewall/ virus protection?

NONE of the above…cheers though…

I have No Antivirus or Firewall on the Studio Pc… I disabled the Antivirus & firewall to allow the Elicensor free range as it were. ALL possibilities Ive exhausted in fault finding…Ive tied an earlier version, same problem!!

Its a complete “frame of mind” changer …spend the bucks…upgrade…Hope for the best>!

The Elicensor is supposed to be bombproof, regarding install etc… This is my first problem with it, The licence WORKS for 6.5.4.but is Refusing to download my Licence for Cubase 7!.

Absolutley gutted…Ive tried 3 computers, all the SAME issue…gets to 15% or so, then the program either crashes, OR simply disappears.

Not funny indeed!!. Havent ANY ideas as to what it could be… The licensor is working for my version of 6.5.4 but as mentioned denies me ANY update to Cubase 7.

Anyone came across this before? :exclamation:

You say you aren’t running as admin?

I run every program as an Admin, Im logged in as an Admin etc…

Running under admin privleges and run as admin are two different animals.

Besides, the proper way to upgrade the license is via the Maint. function in eLCC.

lets not get stuck here bro.

I used 3 diff pcs, I have fully understood how & why etc regarding the Elicensor correct functions, I used the Maintenance Function first. Cleaned the Licence of any trials etc…Then used the Activation tab…entered the code etc…

I appreciate the help, but its got nothing to do with Admin priviledges etc.

I can perform Maintenance.
I can Clean Up the Elicensor Memory
I can send Elicensor Information to the server
I can Update the Elicensor Server Database
I can enter an Activation Code (& It is properly recognised!)

I cannot get the License to Download to the Elicensor, It crashes around 15% EVERYTIME on 3 Computers!.

The same problem is appearing on a Win 7 64 bit system…a Win 7 32bit system etc (As I pointed out, I am logged IN as an Admin…I run the Elicensor with Admin priviledges …The same problem or Error is appearing on an XP PC as well.

I’m not anywhere near an novice. 17 yrs using this bloody program. I certainly had to laugh when I went to the Elicensor site & their video about the new license " updated & streamlined" !..

Feeling mugged a bit, The simple fact is that the Elicensor is not doing what it should. I am well aware of all the situations regarding Admin etc. It is NOT that,thats the issue, Its teh fault being created by the Elicensor.

I have generated a support file (never saw this feature before)

So does anyone know the proper procedure (where & to Who etc)…to send the Elicensor Support file to???

Have you tried this solution in Steinberg tips


It worked for me. Good luck

Go to my steinberg, and scroll down till you see support request form.
Fill that in and add the support file, can take a couple of days before they answer.

Good luck!

I had similar issues. Turned out to be a problem on SB’s servers. Drove me nuts too.
My hope is that you’ll get a quick reply and be up and running soon.


MANY thanks for your input fellas.But I managed to get it!!

After 7 painstaking hours, installing, overwriting files, replacing synoacc.dll/synpos etc etc etc…after trying EVERY single thing I could think of… I managed to hunt out an older Elicensor installation…6.5.1 (version) from the installer disk… It FINALLY accepted the License… The problem is DEFINATELY with the Elicensor Install…my Steinberg key is functioning properly, so all I can add is that this is a seriously flawed issue on Steinbergs behalf!!!

Steinberg I would suggest you HAVE A WORD with your Elicensor providers, as this fault I can gurantee your methods of repair would not have worked regarding this issue…The trials & tribulations I can assure you would not have been solved by your support team. I tried things they NEVER would have suggested… I know I would not have been pointed to using the version of the Elicensor that I used to FINALLY make it work. ( 6 revisions ago???)

Major letdown Steinberg, This major PITA didnt give me any welcome to the world of Cubase 7.

Time to get your finger out, more problems are appearing every revision of the software…but to have issues with the Elicensor is a pretty fatal error!.