EMpty Halion Library Manager

Hopefully this is a quick fix and this the right place to post this.

We had a computer crash, Have successfully reinstalled Cubase Elements 9.5, Halion Sonic 3 and our VTS Sound Loops and navigated the whole eLicenser business. But our Halion Library Manager is empty. Where be our sounds and loops?

We also seem to have a license for Basic FX Suite Rev.2 but can’t find it for download other than as part of the Yamaha UR242 firmware where it would appear to be V1.0.1. Are we confused?




Make sure, you installed Cubase from the Full installer. If you have installed from DVDs, make sure the 2nd disk was installed, please.

Thanks Martin,

We installed from the previously downloaded 9.5 installer that was in our back up hard drive. (Long story short, after my son’s PC crashed, turned out his back-up system image was faulty. We have a back-up of all data, thankfully, but not the working apps.) It does look like Cubase itself is fine; it’s the Library Manager that’s empty. Allowing that we were’t using a DVD and what I’ve stated above, what would be next step?

Thanks again

Noel (and Tony)

How big was the installer ? 10-11Gb ?
Is the eLicenser software up to date, have you run a Maintenance on it ?
Is Cubase installed for All users or for a single account ?

Thanks to Martin and peakay for the replies. We solved the problem with tech support: My son had malware & antivirus apps running during our downloads and reinstallation’s that prevented a successful install. Turning them off and downloading/reinstalling yet again worked. I’m a Mac person and he’s 13 so now we know.Hopefully this will be helpful to anyone else going through similar problems!