Empty Stave again

I try to get a piano (lead sheet style) to hide the empty staves. But I can’t get it to work.

Layout Options - Vertical Spacing - Hide empty Staves is set to “All Systems”.
“Allow individual staves of multi-staff instruments to be hidden” is checked.
Exclude Piano: NOT checked.

Trying to remove the staff by “right click” - Staff - “Remove staff” is greyed out.

What am I missing?



Are those layout options applied to the correct layout, selected in the right side of the dialog?

I hope so… I selected the Piano wherever I could…

In that case, please zip up and post the project (or a cut-down version that only contains a few bars of that layout).

Here’s the Dorico Song.

Thanks for taking the time!
The Test Song.zip (1.04 MB)

Hi Saxer,

Engraving options/ Chord symbols /Position of chord symbols on grand staff instruments, select “Above top staff”

Is selected.

No, it’s not. Go to the Chord Symbols page of Engraving Options, click the Position subheading in the list on the left, and set ‘Above top staff’ instead of ‘Between staves’ for ‘Position of chord symbols on grand staff instruments’.

Oh, I see… I set the chord symbol position in Layout Options - Staves & Systems - Chord Symbols to “Above top staff of system” and the chords are actually written on top. So I have to set this in Engraving Options too to be able to hide staves. Works fine now, thanks!

What’s the difference between both options?

The Layout Option puts chord symbols above the top of the system, only. The Engraving Option specifically puts chord symbols on grand staff instruments above the top of the grand staff instrument (but will be overridden by the Layout Option in circumstances such as yours). If the Engraving Option is set to put chord symbols between the two staves of a grand staff instrument, the bottom stave can’t be hidden (because it would be impossible for the Engraving Option to work).

Thanks a lot for that explanation! Very helpful!