'Enable CD-Text Writing' bug?


I’ve created an album montage and populated the album and track performer/title fields so that I can use this information to create file metadata and tidy file names. I’m creating a DDP and the client has requested that the master does not contain CD-Text. So I unticked ‘Enable CD-Text Writing’ in the CD-text editor thinking that this would allow me to create a DDP without having to remove everything I had entered. When inspecting the DDP I note that track title and track artist is not populated. However, the album title and album artist cd-text has been written.

I am assuming no cd-text should be written at all?


How do you know that?

I have just check it, and you can verify by yourself: when you disable CD-Text writing, the file CDTEXT.BIN is not included inside the DDP folder.

I have disabled CD-Text writing here:

The resulting DDP folder has a CDTEXT.BIN file:

Importing the DDP into Wavelab / HOFA DDP Playermaker… The album artist and title is there. The rest has been ignored.

I’m running latest Wavelab on Mac.

Maybe that’s an old CDTEXT.BIN already present in the folder?
Please try again, on a new folder, and with the latest WaveLab 10.0.70

Its definitely a brand new empty folder and I am running 10.0.70.

Here is a screen capture:

Hmm, I just did the same test as yours, both on Windows and Mac, and no CDBIN is created.
I have no clue.
But try simply erasing all CD Text filed (there is a Reset button in the CD Text editor).


Yes, if I reset the CD text editor then no CDTEXT.BIN is created. However if the CD text is populated and I untick “Enable CD-Text writing” then a CDTEXT.BIN is created. Track artist and track name have been removed. Album artist and album name remains.

It’s a very uncommon request but I thought I would mention it.