Enabling/disabling metronome while recording stops recording

So, I just found this bug, and it is a biggie. Didn’t see anything here about it, so here goes - Cubase 6.0.3 and Nuendo 5.5 both do this. When recording on a track with the click on, I turned the click off while recording. The region graphically continues expanding as expected. But, when I press stop, there is no audio recorded after the click was disabled! This is a SERIOUS issue - I know on Gearslutz people have been talking about it, so it is not a localized issue. Is there a fix on the way for this? I am on Mac, OS10.6.7 with an 8 core 2.8Ghz Intel Mac.

confirmed with a slight detail change:

if you activate the click while recording is running there’s no problem. if you deactivate the click the region appears to continue recording but when i hit stop i see a gap in the recorded audio where i disabled the click but a second region (after the click is disabled) is visible. when i go into record again the second region disappears.

rather worrying.

Confirmed.
In playback also…enabling/disabling causes dropouts.

acknowledged by steinberg.

http://www.steinberg.net/forum/viewtopic.php?f=19&t=3400&start=14

So, is it going to be fixed? The suggested workaround of “don’t disable click while recording” just isn’t acceptable. This was never a problem with any previous versions, so I can’t imagine it being very difficult to get BACK to working properly?