Enabling Musical Mode in pool, some events move in timeline.

Sometimes I’ll decide to vary the tempo of a song and will enable musical mode on all of the audio in the tune in the pool. Sometimes the tempo I’m at will not be attached to some of the files in the pool, and in that case I’ll enter it in before I enable warp (though this seems to be irrelevant to the problem I’m describing). As soon as I enable musical mode, some audio cues will move around in the project, which is a huge problem. Sometimes it doesn’t happen and I’m not sure why/why not.

The only way to avoid this problem in the cases where it happens is to bounce the events that are moving around, but this can be very complicated and time-wasting depending on the session. I’m coming from PT where this was not an issue ever (i.e. everything remained exactly where it was in the project window when enabling their version of Musical Mode) – there was no extra bouncing of audio needed, etc.

Am I doing something wrong or is there something else I need to do in order to ensure that some of my audio events don’t move somewhere else when I enable warp?

It may be how you have your tracks assigned to Musical Time Base vs. Linear Time Base. Try it again, starting from scratch, with all tracks set to Musical Time Base, that may work. If not, some trial and error after reviewing that in the manual may help. Of note, there’s a Project Logical Editor that lets you toggle all tracks at once between the two, saves a lot of time in big projects.

Also, not a bad time to take a look at the section on “Set Definition From Tempo” while you’re working through this, for times where the tempo isn’t one constant value.

Thanks alexis. All of my tracks are set to Musical Time Base by default, but I will take a look in the manual at those sections.

So…I looked in the manual at these things and was unable to remedy the issue. What I want Cubase to do is like PT does: No matter how many slices of an audio event you have, they always stay where they should when you switch it to Musical Mode so they will follow tempo changes. In Cubase, sometimes they move different places. All of my tracks are by default in Musical Time Base mode (unless I manually switch them to Linear Time Base mode for a specific reason, but in the projects where this issue happens that is not the case with the tracks in question), so that is all in check. Bouncing the audio tracks is not an option because I like to have access to all the edits and individual slices in many cases, which would result in having to bounce huge amounts of individual events.

Any ideas why this is happening? I remember reading about others having this issue here a while ago in C8.5.

I don’t have that problem, so it’s probably just a matter of figuring out your steps, trying to help you troubleshoot a bit more:

  1. just to confirm, are you saying it sounds wrong as well as visually looks wrong after you warp the tempo?

  2. is your song at one tempo, or a variable one? If the latter, “Set Definition From Tempo” will probably be needed.

  3. when my audio bits sound sound good before I warp the tempo, I don’t go in the pool and adjust any tempos. Not saying you’re doing anything wrong, just that I skip that step.

  4. just to confirm, in the first ¶ of your first post, when you say you warp enable the audio parts, do you mean you click the box that says Musical Mode?

  5. When you say things are moved around, do you mean “a lot”?

Thanks again for your help alexis.

  1. It sounds fine, it’s just that some of the actual events get moved elsewhere from where they were originally.

  2. One tempo.

  3. I usually can skip that step, too. The only time I do that is when the original tempo in the pool is wrong or non-existent for some reason, which occasionally happens. But that doesn’t affect the issue I’m experiencing.

  4. Yes - sorry, should have been more clear with that.

  5. It varies – sometimes they move a lot, sometimes a little. And often it doesn’t happen at all, which is the difficult part!

Note: If I bounce any of the problem events that are moving around (i.e. bounce them before I enable Musical Mode on them), then everything is fine. Seems like there could be a weird time stamp on some events that gets confused when Musical Mode is activated on them?

Is your ruler in bars/beats mode, or minutes/seconds? If it sounds just fine after warping but the audio parts visually look different, maybe it’s just how they are displayed.

Any chance you could attach a before and after screen shot?

OK, this is getting to be very serious. It doesn’t happen in some sessions for some reason. It shouldn’t happen in any.

An example: Just had a writing session and recorded guitars and vocals in Cubase. I edited and moved around the parts a lot, then we decided we wanted to try a faster tempo, so I selected all of the audio in the pool and enabled Musical Mode in the pool. At that point, some of the events jumped around to other places in the project (i.e. entire events moved to other locations than where they were – it has nothing to do with how the events look, I’m instead talking about the fact that some of the events actually get moved somewhere else from where they were originally), while some (the majority) didn’t. This should not happen at all – every event should stay exactly where you have it placed in the project, after enabling musical mode in the pool. They should not move unless YOU move them yourself. In my case every track is set to Musical mode, but the Track mode is totally irrelevant to the problem - it has no relation to what’s happening. I’m not sure why it happens to some events and not others (maybe the problem has something to do with the original timestamp…although some of the events that move are in the exact position that they were recorded in). This happened in C8.5, and my studio mate says that it’s been happening for as along as he can remember on Cubase (Windows for him, Mac for me). Bouncing everything is a clumsy and bad workaround, for a number of reasons.

Anyone know why is this happening, and is there any way around it? So frustrating…! It’s these kinds of things that very specifically affect one’s work in a very significant way. :cry: I really hope there’s something obvious I’m missing.

That happened to me too in Cubase 5 back in the day. I don’t remember any details, but it definitely looked like a bug to me, not like it was something to do with program settings. I think I’ve never experienced in later versions of Cubase. I’ve never used version 9 though.

Interesting! It happened to me on 8.5 at times as well, but not consistently, same as C9. And like I said my studio mate says it’s been happening to him (off and on, like it is for me) for years and years. If there’s no way to keep it from happening then it’s 100% a bug that should have been fixed years ago.



Is your ruler in bars/beats mode, or minutes/seconds?

If it’s in minutes/seconds mode, try putting it in bars/beats mode and then try to reproduce.

If the problem is still there, can you post before and after screen shots?

It’s already in bars/beats mode, yes.

I’ll post pictures some time today.