Engraving avoid collision tips?

What’s the best way to make Dorico avoid these kind of collisions by itself? I often don’t have the time to go over the 200+ page scores on a deadline and would love to hear any tips in making Dorico handle these things well. I played with ideal and minimum gaps and it helped but still getting these collisions.

Unless we see the entire page length, we cannot tell whether the page is overfilled or the staff size is too large for the paper size.
https://www.youtube.com/watch?v=udfPlwq-r_o

Here’s the entire page.

This video might help.

I have watched this already, thank you Craig.

Normally Dorico won’t allow collisions like those. There are several things that can override collision avoidance. Have you forced a certain amount of music into the frame? We’ll need to examine a file (at least a couple of pages) in order to help.

It’s really much better to share the file if possible. What is your inter-system gap set to?

I’m not able to share file publicly on this one, though I would be open to sharing with a team member. There are no manual engraving overrides in my score, I’m really trying to avoid doing that if possible. The previous example is now fixed, but I’m having some overlapping systems now as in the example. I’m also attaching some screenshots of my layout settings. Am I doing something wrong to cause this? again, no system/frame breaks or other overrides in these examples. If possible, I would like to learn how to tweak settings to fix these problems rather than manually fixing them.





Some of those values seem a little large for me - inter system gap(10), inter system gap with content (20)

Tweaking these should help

I have “1” and “2” for the inter-system gap settings. I suspect that 20 is far too high, causing you problems.

All these values, including the “Ideal” settings are MINIMUM values. They are the smallest that Dorico will allow. Keeping them small allows Dorico room to spread things out.

@benwiggy 's settings are the Dorico default here. I would never dream of using such high inter-gap settings – it doesn’t even look right on the score to me. If things are getting squashed, I would try to just reduce the rastral size and change nothing else from the defaults to see what happens then, if you haven’t already done this. With defaults, I’ve never had a score to look anything like this

Yes, the gaps you’ve chosen on the Vertical Spacing page of Layout Options are much, much too high. You don’t really want Dorico to ensure that two adjacent staves that are part of the same system should always be at least 8 spaces apart – don’t forget, 8 spaces is the equivalent of the height of two five-line staves.

The way I prefer to think about these values is that you should rather set them to the smallest value you would be willing to accept. You can get away with values as small as 4 or even 3 spaces for the staff-to-staff gap. And you should likewise only set a gap of something like 8 or 10 spaces for the gap between systems.

The reason for this is that specifying smaller values allows Dorico a freer hand when it comes to vertical justification and using up any extra space between staves in a smart fashion. But if you force Dorico’s hand by saying that it must leave 20 spaces between a system (the height of five staves!), then obviously every page is going to end up overfull, with the result that Dorico ends up squashing the music uniformly, i.e. working out by how much the page is overfull and then dividing that amount between every staff and system gap on the page. This is bound to create unnecessary collisions while leaving huge gaps everywhere else.

Be much gentler with the way you approach these vertical spacing values, and you will get much better results.

1 Like

You’re right. In my attempt to separate the overlapping systems, I made the the distances too high and not even realize what it was doing. Your reminder as to what a "space"means is very helpful, makes it easier to foresee the effects.
I’m getting closer to a good result, but I’m still way too slow. I often finish composing a day before the deadline on large scores and don’t have time left to review hundreds of pages carefully. Something like “optimize” was a good tool to make sure there won’t be big collision issues anywhere. Something like that and page turn assistance for parts would save tons of time, for my workflow at least.

But that’s just it, if you set the Ideal Gaps and Justification values correctly, you don’t need an Optimize feature, because there won’t be any collisions.