Enharmonic respelling keyboard shortcut with note name above broken in (german) v5 (Mac)

The shortcut Alt-´ for enharmonic respelling using note name above seems to be broken for me in v5 Mac OS 11.7.10.
The shortcut is defined in the keyboard shortcuts. Deleting it an re-defining doesn’t do any difference.
The shortcut for respelling using note name below (Alt-ß) works.


On Windows on a U.S. QWERTY keyboard the shortcut is OPT/ALT + + to access the enharmonic equivalent above.

Thanks, Derrek.
On the german keyboard it is Opt/Alt-´. It used to work with previous versions.


I’ve noticed too some keycommands are dead with Dorico 5. The one I’m thinking about now is the Navigate to previous layout. I think there’s been more of this kind of keycommands problems with v5 than before, but I might as well be biased :person_shrugging:

I think this will very likely be a casualty of some pretty significant changes in the shortcut handling in Qt 6, which Dorico 5 uses (Dorico 4 was using Qt 5, which had its own problems which we had mostly managed to work around). We have an open support ticket with the support people at Qt about some issues with e.g. the Spanish keyboard layout, and I suspect this is more of the same.

When you type Alt+´ into the Key Commands page of Preferences to set it as a shortcut, what character(s) appear?

1 Like

Dear Daniel,
I don’t understand whether this question is directed to me or not. [Edit] I see that it is not !

Here are my keycommands for previous and next layout :

^ is a diacritic, so it should explain why it’s causing problems. But it used to work before… and it appears perfectly in the keycommands editor. ^ and $ are placed where [ and ] are in an English keyboard layout.

It shows the accent character.
Keyboard Shortcut

If you assign that combination to the respell command, does it work?

No, this is why I asked about it.

If you press that key combination in a regular text editor, does it produce a complete character, or does it produce a combining diacritic, waiting for you to specify the letter to which it should be added?

On the Spanish keyboard on a Mac, the enharmonics are the key combination opt + “¿, ?”. I have also had problems with midi regions with the “)” key and I solved it in preferences, keyboard shortcuts, assigning another shortcut not used by the system Technical support is aware of other anomalies.I am new to Dorico and the majority of errors are beginner and the English language.

Without the Alt key it is the accent for the letter you type afterwards (it shows the accent together with an underline, waiting for you to type the desired letter).

Together with the Alt key there is some strange behaviour. The first hit shows for a moment an inverted superscript comma (= single ending quotation mark), then it turns into a normal comma. From the second hit on it produces immediately normal commas.

In which application are you seeing that behaviour, Joachim? In TextEdit or another similar text editor?

In TextEdit as well as in Pages. Not so here in the forum text input. Here it produces exactly the character shown in Dorico (').

So that key combination if a dead key of some kind on the German keyboard layout, or not?

I am not sure what you mean with dead key. Together with the Alt key it produces a proper character:

( FYI the dead keys in that layout are the ¨ and ~ outlined in orange, showing that they will combine with the next letter typed. )

Thanks. This is all more difficult for us to handle now than it was when we all worked together in the same office, because now our various keyboards for different languages etc. are in different places, and laying my hands on one of our German keyboards is difficult.

My suspicion is that this problem has the same root cause as some of the other issues with non-English keyboard layouts that have been introduced in Qt 6, and we’ll take this to their support team and ask for help.