Entering notes using the computer keyboard Alt + Shift not working as described

Good afternoon friends.

I have always used a Finale + DAW flow, but I am giving the Score Editor a try in case I can start working exclusively on Cubase (also as I am still debating between the Pro and Artist version of Cubase during my trial period).

The instructions on: Entering notes using the computer keyboard

read, as far as I can understand, that in ALT mode, I can hold alt (the note input changes as expected) and that I can use SHIFT + arrow to change the note duration before input. This DOES NOT work.

Shift + arrows work correctly when NOT using ALT mode, but when using ALT mode I cannot seem to be able to change the note’s duration. Obviously, not using the ALT mode deprives me of a lot of other functionalities, so I am a bit confused as to how to achieve this.

Also, when entering notes, the duration is always set to the full duration of the note, which makes for a very poor performance. I have not been able to find tricks on how to mitigate this other than editing each note’s single length and then re-setting the note’s display length in order to avoid having spaces all around.

So, I am kind of battling with the Score Editor… maybe it’s simply not the tool for this?

Thanks for any feedback. Best regards,
Rafa.

First, your link points to Cubase 9 version.
If you are coming from Cubase I’d suggest Cubase Pro 12.
And the score features in Cubase Artist are very limited, it’s not for you.

Regarding your question, if you want to use ALT key in computer keyboard entry mode, in order to change note lengths before entry, you would have to use this mode in combination with note insert length key commands that you can find in Key Commands inside Set Insert Length folder.

By the way, I too used Finale +25 years ago, then switched to Cubase Score Editor, and never looked back :wink:

1 Like

Thanks so much! I am, obviously, trying out Cubase 12 Pro (still on my trial), thanks for bringing to my attention the V9 stupidity from my part… on my defense, there is not a single clue you are on that version on the title, links or anything else other than the URL link. I reached that searching the web. I believe it could be clearer. Still, my mistake, nonetheless.

I will read the current version’s manual, check your suggestion about the Set Insert Length and get back to you. It’s encouraging to read that you were able to transition from Finale with success.

I, for one, I’m having a lot of issues: I insert a quarter note, it works nicely… I insert then an eighth note and it inserts a quarter note, but puts the cursor an eighth after the previous note. So, if I insert a new note, it will convert the previous one to an eighth, but I cannot leave a rest for that eighth unless I enter a note. But that is probably the place for another question.

Thanks again for the input! Really appreciate it.

Best regards,
Rafa.

First, check the Display Quantize in your score and adjust it according to your needs.
Do the following :

Turn on Quantize in the extended toolbar
image

This will make appear all Display Quantize indications in your score.
Double click on the nearest Q event to the left of the position where you want to insert notes, to change its settings to something like this:
image

These settings will be applied to your staff until the next Display Quantize applied to that staff.
Let us know if it works.

Thanks! This appears to have worked, I’m still a little fuzzy about the specifics why this was not applied from the start as I believe I had selected 16ths, but I’m OK with it for now.

If I can abuse your huge help so far, is there a way to: after entering the notes with the correct “score length”, adjust the MIDI length WITHOUT AFFECTING the Display duration length? Here’s my scenario: I enter the notes via the score editor. It works, but the notes are playing all the way up the next note. This is more a “marcato” passage, so I select the notes and reduce the MIDI length (in the score editor with the Note Editing Overlay). It does “sound wise” what I wanted, but then the notes change display length and rests appear all over the place. So then, I need to readjust the display length back to full length in order to re-set the score "cleannes '. Is there a way to just adjust the MIDI note duration while keeping the existing Display duration? Thanks so much,

Rafa.

There are multiple options for the Note Editing Overlay feature:

Edit MIDI Note Duration
image

And …

Edit Display Duration
image

Yes, exactly! But if I change on M mode, the D line also gets moved. If I change in D mode, the M line stays. I want to edit the M line and have the D line remain without having to get back to moving the D after moving the M.

Sorry if I wasn’t clear.

Rafa Pólit

I see now. You are right. This is by design. But, for any given note, if its note display duration is different from its MIDI duration, you can change the actual duration of a note in the Key Editor without impacting its display duration in the score.

:bulb: Maybe an idea for an improvement regarding the Note Editing Overlay feature: using a modifier key (ALT, Shift, Ctrl or Cmd) to change the note MIDI duration without affecting its display duration.

Most definitely a good feature to have added. Or maybe a preference? Sync MIDI duration and Display Duration: ON / OFF. If you put it off, you need to modify them separately always.

Thanks!