Errant lyric hyphens

In the attached file, the new setting to omit leading hyphens is set correctly, but there’s still a hyphen at the start of the second system, second stanza, that I can’t get rid of. Unless I’m missing something.
Canticle 2 Contemporary Folk.dorico (1008.0 KB)

IIRC I had a problem with that setting and a particular thing (change of clef, of key signature ? I don’t remember) that was fixed almost instantly by Daniel… My guess is it will be fixed for next update too :wink: