Error 1603 Trying to install trial (solved)

Windows 10.

Installer file is on drive ‘F:’. Selected drive ‘F:’ for installer files.

Tried installing with check for update and without. Same issue.

Gets to prox. 75% and then error dialog appears.

Error 1603. Then something like ‘problem with package.’

Any ideas on what to do?

Please tell the exact error message.

  1. “There was a problem with the installation package… Contact the vendor.”

  2. Then a second dialog box with a red X which says

“Error 1603”

Hi,

are you trying to install the Wavelab Pro or Wavelab Elements 9 Trial version ?

cheers
Kay

Pro.

FWIW: I already have WL 7 installed.



Since you’re doing this on an alternate drive, it seems likely that’s the unusual problem.
Look at “Grant Full Control permissions to the SYSTEM account” at the bottom of this page:
https://support.microsoft.com/en-us/kb/834484

Didn’t help.

The SYSTEM account already had ‘Full Control’ over the C: drive and the F: drive.

I re-downloaded, but this time to the C: drive.
Then I ran the install program as Run As Administrator

Then I parted my hair on the left and twirled 3xs to the right and did a rain dance.

No difference.

It shouldn’t be this hard.

Any other ideas, guys?

Hi suntower,

delete the installer you have and try downloading it again but with a different internet browser.

Hope this helps!

No difference.

The only change in my system is that this my first SB install since updating from Windows 7 to Windows 10.

I’ve been happily using SB installers on the same hardware for 3-4 years.

I’ve tried now with 3 different browsers, on 3 different install drives. I installed the eLicenser activation (no problem.)

Same symptoms every time.

The only other detail that might be relevant: I use a desktop management program called ‘Fences’ which is pretty popular. Never caused an issue before, though.

Now what?

Any word on this… Same problem. Tried all suggestions in detail but same results.

PG? Luis? Anyone?

Please advise. I am -dying- to get past the WL7 UI.

TIA,

—JC

Start Registry Editor (Regedt32.exe), and then create the following path and keys in the registry:
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

Create keys:
Logging : voicewarmupx
Debug=dword:00000007

Quit Regedt32.exe

Try to install WaveLab.

Once it has failed, look into the folder %temp%
(type %temp% from the Windows Start menu). In this folder, look for a recent file that should be the log of the installation procedure. Pass that to me.

La voila…

TIA,

—JC

PS: To anyone else who may have to do this… or a suggestion to whoever writes the install program. I had to do this twice. The installer deletes the log after install which is STUPID. If the install fails, the log should persist! The second time, I made sure to grab the log when the error message appeared (but before finally exiting the installer).

setupLog.rar (1.99 KB)

Not the proper file. See the file I get when I install; different name and much bigger.


The exact name might vary.

See also my registry:

Let’s try this…

—JC

wavelab9.rar (143 KB)

The log shows that the installer fails to register something to Windows. The Windows function fails. This means there is something wrong in your Windows 7 installation. However, maybe, there is a solution. Please try to install:
Microsoft .NET Framework 4.6

https://www.microsoft.com/en-us/download/details.aspx?id=48130

Then reboot.

Bon jour…

  1. I’m on Windows 10.

  2. In any case, I tried downloading NET Framework 4.6 and I get this error msg:

.NET Framework 4.6 or a later update is already installed on this computer.

… and it refers me to this web page:

https://msdn.microsoft.com/en-us/library/hh925569(v=vs.110).aspx

…which seems to indicate the .NET is now built into Win 10.

So, now what?

—JC



Try this (if this is possible): when you get the error message, make a copy of this folder:
C:\Program Files\Steinberg\WaveLab 9
Later, this folder will be erased, after the installer failed.
Then, try to run WaveLab from the folder you have copied.

I got an error ‘WMVCORE.DLL’ is missing’.

Which led me down a rabbit hole…

I believe the problem is that I previously had Windows 7 “Ultimate N”… which was the EU version of Windows without IE or Media Player. See this:

https://support.microsoft.com/en-us/kb/3099229

After installing this Feature, WL9 installs. Woo hoo!


SO TO ANYONE ELSE WHO HAS TROUBLE INSTALLING AND HAD THE ‘N’ VERSION OF WINDOWS…

In one sentence: you need to install the above Media Feature Pack. The WL9 installer won’t work without it.

—JC

PS: Something of a Rant: I’m sure I’m not the only person who used Windows 7N and is now going to face this issue. I have been happily using WL7 and WL6 and Cubase 8.5 without problems. My fear is that if SB’s new installer protocol depends on having Media Player, then I’m kinda screwed. I don’t think the installer should depend on -any- external programs like this. OR AT THE VERY LEAST, if it errors out, it should tell you… in plain language… that you need that Feature.

PPS: I’ve only had the program running for 5 minutes but already I gotta say… WELL DONE. I’m sure I’ll have grouses, but the reason I’m writing is this:

Unlike WL7… which I’ve been using… and WL8… which I didn’t get…

I CAN ACTUALLY FIGURE OUT THE UI! WOO HOO!

IOW: The second WL9 opened, I knew what to do! Whereas, the previous versions were a complete mystery to me.

I’ve been -suffering- with WL since I upgraded from WL4. So this is big, Big, BIG.



I knew this, but the original error message was very uncorrelated.
Good that you found the solution!

You should add this to some sort of FAQ. Or change the installer to not depend on this function.

Thanks.