Error Code 28 - ProtectExecuter

I cannot use Cubase or any application that uses the eLicenser.

No drivers are available from Windows Update and I cannot unpack the exe to extract a .inf file and driver catalog.

I think it’s about time Steinberg looked at putting the driver update files with Windows Update, since as of now I am looking at a complete re-installation just to see if the drivers are compatible with the latest update for Windows 10.

I’ve rolled back, run the Media Creation tool but to no avail.

I can try a Reset (at least Microsoft fixed that after SFC /scannow and DISM).

This is really unfortunate that over petty software protection, I must be out of action for at least a day.

If anyone has any ideas, please write me back.

No, it’s about time to install the elicense application. It installs the correct driver.
You only see the protect executer in the device manager if elicenser manager is not installed.

Hi Raphie,

It’s saying that further actions must be taken in the Events tab in Device Manager, even after I have installed eLc.

Just delete it and scan for changes. Should then normally update to elicenser.

It’s saying there is no compatible driver, yet there is a driver installed in the Windows folder.

Has anyone else encountered this?

Try installing the eLicenser as admin.
Although it should do it by itself, but it is worth a try.
Maybe try a different USB port for the dongle.

Hi Peakae,

I tried Admin, and different ports.

It seems the driver is no longer compatible with Windows 10.

Short of a complete re-installation of the OS, just for this one device; it seems a bit over the top as a solution which is not guaranteed in any event.


I’m running the latest Windows 10 and Cubase 9 no problems.
Do you have any antivirus software installed besides the onboard win10 ones ?
Have you downloaded the latest version of the eLicenser software ?

Are u using the latest elicenser from ?


Yes the last one as of September.

It was working fine until a few days ago, then Dorico stopped loading.

I could see ProtectExecuter showing in Device Manager when the device wasn’t attached and previously this was not an issue and it showed “eLicenser” once the device was plugged in.

Previously, as I recall, it would only show ProtectExecuter when viewing hidden devices and in compatible OS’s (of which Windows 10 is not) eLicenser would be gray.

I used Windows Troubleshooting and that has worked so obviously the driver is only compatible in Windows 10 with Windows 7 settings.

My message to Steinberg:

your protection software is no longer compatible with Windows 10 and as there was nothing mentioned in the website, I think this is a quality issue that must be rectified ASAP.

I don’t think that’s the right conclusion as it works fine for all the other users on Win10, something happened with your system.
did you uninstall all protect executor devices? remove he physical key, run cccleaner, reboot, install latest elicenser, insert elicenser, this should work.
if this doesn’t work you will need to reset your windows, OR…
if you have changed USB ports, you might want to try a different port.

Done all the cleaning, I’m always up to date.

It was quite strange behavior actually, first Dorico, then VEP6 and Cubase all stopped one after the other.

I don’t believe the Device Manager events system would be false, although I did have the same issue for a Novation SL MkII and had to do the same Troubleshooting.

At this stage, I am just glad I don’t have to Reinstall or Reset Windows.

One thing good, however using the Media Creation tool actually fixed the Reset functionality for Windows so of course I could try it and see if I have to use Troubleshooting again.

I’m on a HP Laptop with TPM, and UEFI, DEP with signatures enabled so I’d not be surprised if my conclusion is correct. I can’t install anything below Windows 10 so maybe it’s a warning for SB that eventually everyone will have to use troubleshooting and at one stage or other it will simply not work (hopefully by that time we will have a more modern licensing system in place in any case).


Is it working now then?

May I ask you a question instead?

Have you tried to install eLC from a clean install yourself under Windows 10?

If not, how would you ascertain what I am saying is the “wrong” conclusion?

Yes ofcourse with probably 80% of the windows userbase here.
There are no problems on a virgin win10 install. The problems you experience are not caused by windows 10

Exactly, the driver is no longer compatible.

It’s your system. Reinstall or reset it. Only way to start with a clean slate.