Error installing Tools for UR28m 1.1

Hey,

I’ve created a support ticket about this but I thought I’d post here as well in case anyone else has a similar problem…

I successfully installed Tools for UR28m (latest version, 1.1) on my Windows 7 x64 laptop. I then had the UR28m working/passing audio with no issue.

I then tried to install the same tools on my PC (again, Windows 7 x64) but got the error:

“Error applying transforms. Verify that the specified transform paths are valid”.

I uninstalled Tools, via Control Panel, and tried to install again. Same error message.

Has anyone else encountered this?

Google seems to suggest that there was an issue during installation and that I’m probably not do a ‘complete’ uninstall. Is there a a way to check that the Tools have been fully uninstalled, or can I manually uninstall? Of course the problem could be something completely different.

Any help would be most welcome :slight_smile:

Thanks,
Stephen.

PS - after the error message I do get another dialog telling me installation was successful. On checking the device the new driver is there and reported as working, however the properties cannot be updated via the control panel (it hangs) and the device is not passing audio, so my guess is that the installation was not successful.

Anyone any ideas? Is there anything else I could try that immediately jumps out? Maybe a registry cleanup?

FAO Steinberg - are there any registry settings which might be hanging around that could be (safely) removed?

Help me Obi Wan :wink:

Also tried some registry cleaning utilities, re-boot, re-install, same issues…

Anyone know what the average response time is for a support ticket round these parts (3 days and counting here)?

I’d like to get this resolved, if possible, by the weekend, so I can put this thing through it’s paces. I don’t really have long left before I’ll have to send it back, unfortunately, which is a shame because it seems like a nice piece of kit.

For reference, I’ve received a response from Support, requesting that I run the following tool:

http://support.microsoft.com/mats/program_install_and_uninstall/en-us

I’ll report back when I’ve had a chance to do this tonight. Fingers crossed!

Success!

For reference, I downloaded and ran the utility, as suggested above.

I chose the “Detect problems and fix them for me” option and then “having problems with install”.

I was then prompted with a list of programs, from which I could select which I was having a problem installing. There were two instances of “Steinberg UR28m Applications” in this list. I selected one of them and the option to try to uninstall. I then repeated the above steps to clear the second instance.

Then rebooted.

After that I was able to run through the installation without any issues, and I’m getting audio!

Quite a useful general purpose utility.

Thanks to Steinberg for the help.

Cheers,
Stephen.

Thanks for the report! It’s good to know that this tool did the trick for you!