Error opening file and black screen after trying to import MusicXML from Playscore2

I am exporting some MusicXML file from Playscore2 into Dorico 5 for iPad.
However, it seems I now have a specific file that causes an “Error opening file” dialog in Dorico which then results in a black screen (I have to close/reopen Dorico, I would expect the “start screen” instead?).

Note I have imported files from playscore2 in the past without issue, so it is probably something specific (as check I also could open the MusicXML ok in NotateMe)

Attached is the MusicXML causing havoc
LieverDanLief, (13.2 KB)

On my Mac, the XML file imported into Dorico Pro 5 without any error messages.
Here it is saved as a Dorico project after importing it.
LieverDanLief,SSAAB.dorico (1.4 MB)

1 Like

Thanks Steven, good to know it works ok on the Desktop version.

It seems however that I have the same error trying to open this Dorico file on my iPad (v5.0 of the app).

I did not expect there to be a difference in MusicXML/Dorico file handling between Desktop and iPad version (I do also have the desktop version, so I will continue there instead)

Have you tried the old standby of restarting the iPad?
If computing devices are left on for a long time, even in sleep mode, a restart can often help.

I can confirm an iPad restart did not solve the issue

That’s a pity. Sometimes a restart helps, sometimes it doesn’t.
Hopefully the Dorico team, and maybe even other users, can have a look at it and see what might be causing the problem.

I’ve just opened the MusicXML file you provided in Dorico for iPad on my own device and encountered no problem. Can you be a bit more specific about the “black screen” you’re seeing? When you open Dorico to the Hub, and you then open the MusicXML file from a location on your device, what happens? Do you see the “Opening” spinner with the percentage progress indicator?

That is weird, I just see the below picture, no progress circle (hence me referring to black screen)

It seems this happens only when opening this musicxml from the files app.
Opening from the hub inside Dorico works fine
The same is with the Dorico file Steven created, that also works when opening from the hub but not from the files app.

The files were in my download folder, copying to another place gave the same result.

This issue also occurs when exporting from PlayScore2 and using “open in app” and selecting Dorico (which is what I normally do)

Try renaming the file so that it doesn’t contain punctuation like commas, and then see if you can send it directly from PlayScore.


Removing the comma (,) in the filename fixes the issue opening from the files app, thanks! Weird

(Edit): Also works now with “open in app” from playscore2