Error with Playback Templates/Expression Maps and built in Playing Playback Techniques

I’ve noticed that built-in Playback Playing techniques, dynamics, etc. will throw off the playback template I have built, even when I have nothing set for those variables.

For example: I added a playback option for ‘staccato+a2’, but when I put an accent over the staccato, the playing playback technique somehow kicks in, and creates an error, meaning in the end only the “staccato” will play, not “staccato+a2”.

Oddly enough this error doesn’t happen when I add “fp” etc. meaning it must happen only for “accents” and perhaps a few others.

Have you checked to see if your technique staccato+a2 has a playback technique attached to it? I have two guesses hear:

1.- The playback technique has a staccato as default playback or
2.- Your expression map has a trigger for accents

My “staccato+a2” does have a playback technique attached, and no, I have no technique associated with “Accent”. In fact, when I remove the accent, the playback does what it is supposed to. However, this shouldn’t be necessary, and I would like to have the dynamic bump from when I place accents without them breaking other playback techniques.

OK, so please tell me what is the Playback Playing Technique associated to 1.- The Staccato and 2.- The staccato+a2?

And also, did you check the actual expression map for the “accent”? Sorry if this is obvious, I’m just making sure we understand each other…

I suspect it might be the changes to velocity etc. that are produced for articulations as defined on the Dynamics page of Playback Options that might account for the difference?

But that shouldn’t trigger a different articulation though… No?

I’d say you need an entry for “accent + staccato + a2” in your expression map as well…

I’ve attached some photos just so you can see what’s happening.

This is what happens without the accent (notice in the playback how the correct playback is called)

This is what happens when an accent is added (notice how the staccato playback is removed, as well as the accent, so you just get “a2”)

My Playback Template (“Expression Map”) contains entries for:

but does not contain entries for:

Could you attach a small sample project that shows the problem?

Sure thing Paul

This is the file demonstrating the issue. You’ll notice when you go to the Play tab, under the playback settings the expression map lane will call for the wrong articulation. I’m expecting a “a2+staccato” patch, but for some reason the accent changes it to a “a2” patch (which is reflected in the playback). This is not true of other “built-in” dynamics playing techniques like ‘fp’…
Dorico Accent Playing technique (525 KB)

In my experience an Accent in Dorico will overrule a Staccato, so unless you define an entry for “Accent + Staccato + a2” this is bound to happen…

I can confirm that adding an entry for “Accent + Staccato + a2” does resolve the issue, but it seems to me that it shouldn’t be necessary in the first place…

I can confirm that too, but then it doesn’t actually play an accent. it’s just playing the staccato patch with the same dynamic.

I have now had time to look into this in detail and I’ve found first that it’s hard as a user to work out what’s going on because the Playing Technique lane display in Play Mode only gives part of the picture. It shows which set of playing techniques from the expression map are being used, ie the entry in the Techniques table in the Expression Map Editor (internally we call these the ‘extrinsic’ techniques). However, we also have a set of playing techniques for which we have some fallback behaviour if they’re not specified in the expression map, such as accent and staccato (we call these the ‘intrinsic’ techniques).

What’s happening here is that for the second note, the current set of active playing techniques are a2 + staccato + accent. The playing technique resolving code has to find the best way of playing it from the set of available entries in the table, but there isn’t an exact match for it. Currently the logic that looks for a fallback only looks to see if you have an entry for a2 or staccato or accent. So it resolves this note to the a2 switch and then applies the staccato and accent intrinsics (ie play shorter and louder).

We don’t yet have any logic to deal with the case of matching a subset of all the techniques. This is what you are (naturally) expecting, so that it would resolve the note to use the a2+staccato switch and then use the accent intrinsic to play louder. Somewhat surprisingly, I think you’re the first person to discover this limitation in the whole 2.x application cycle. Now we’re aware of it I’ll log it and hope we can fix it in a future version. We’ll also try to find a way of showing more useful information in the Play Mode view so that you can get a clearer idea of what it’s actually doing. Unfortunately I can’t think of a workaround at the moment to get the effect you want, aside from dropping the a2+staccato entry, but I realise that’s not ideal either.

Thank you so much Paul. It’s been so fantastic as I come across these issues that the community and people at Dorico have taken time to address them. I never got this sort of treatment when using ehem another Notation Software…

For now, adding the “a2+staccato+accent” and increasing the technique velocity does function as a workaround for me, but I’m so glad you guys are figuring out a solution for the long term.