EUcon not working

Since the upgrade to Cubase 12 Eucon does not work - only the faders are assigned correcty, all buttons on Artist Transport do not work, neither do others.

I must admit that things like that make me angry …

Have you checked to see if you have a Cubase12.xml file in C:\Users\your user name\AppData\Roaming\Euphonix\UserSets\MC2User\MC_USER_SET__Root ? (windows… not sure where this is in mac)

Hi cpechet, there is not Cubase12.xml to be found. only the cubase11.xml file. I am afraid that the installer does not do what it is supposed to do (once again).

Hi… Copy the Cubase11.xml to Cubase12.xml and it should work.

Thank you so much cpechet.
Do you by chance happen to know whether this is an oversight by Steinberg, iow the installer does not do what it is supposed to do? Or is it specific to my system ?

Hi… It has always been this way with the Euconn xml file with each Cubase update so the issue you are experiencing is shared by all Eucon users. I keep a cheat sheet near me for when a new version of Cubase is released because this always happens.

Hi cpechet, you helped me - it works now.

To Steinberg: could you please be more professional in this respect? I mean, C12 is excellent as it seems - so it would deserve a professional handling also concerning installation and “details” like EUCON…

I have the same problem but cannot find Cubase12.xml where would I find this and then do I simply copy it and then paste it to the MC_USER_ROOT

See the Posting from cpechet - it contains the path to the Cubase12.xml . I copied that and now it works now!

I have checked and there is nothing in that directory

Eucon and Cubase 12 Pro working perfect here Dock and S1.
Win 11.
Have you update the Avid software?

Hm… there should be a cubase11.xml - if you rename this or copy it to cubase12.xml it should work (it did so here).
Of course this only works if cubase11 was installed before.

Hi Elien thanks a million for your help, I found the Cubase 11.xml and copied it to the file mentioned above. Do I simply need to change the name to cubase 12.xml or else where can I find the Cubase12.xml so as to copy it to this directory? Sorry if I’m getting this all arse-ways I’m not very good at this!

Hey you - no reason for being sorry. You ask valid questions and want to be creative with cubase :slight_smile: THe forum is here to help people.
I suggest you copy the file cubase 11.xml and rename the copy to cubase12.xml. Thats all.

hi, Is there a solution for Mac?
Does anyone have a clue to solve this?

I have a similar problem with macbook M1Pro Ventura 13.0.1 In stalled EuControl ok but Cubase setup ‘Add Device’ doesn’t see any EuControl whereas the Steinberg SKI remote I later installed is visible in the add device dropdown. I’d love to know what is going on here.

1 Like

Bonjour, J’ai un problème similaire avec mon iMac j’ai une MOTU 896Mk3 j’ai fais la mise à jour de Cubase 11 à 12 toujours le même message no valid eucon sur votre système je ne trouve rien ? bonne journée à vous


hi Christophe
have some news ?? How to solved this problem ?? I have same …
thanx Tibor