EUCON users - question

Hi all,

I switched to windows 10 pro and the latest eucon artist series software version. It works fine so far, except for the following:
Despite having selected that Eucontrol should start automatically, it simply does not.

What am i doing wrong?


Thx, Ernst

No idea. It works here. I had an issue with Mackie mode not working on launch with a prior build but they fixed that months ago. Put in a support request with Avid. They were good about getting back to me and troubleshooting my issue before resolving it in a later release.

Hi you,

so your Eucontrol starts automatically when windows 10 boots and you enter your windows?

Did you run the installer as administrator?


Yes, EUControl just starts with Windows 10. I don’t recall if I ran the installer as Adminstrator, but I suppose it wouldn’t hurt for you to try it.

I did that - and I delayed the Autostart of Eucontrol. I think the point is that it asks for permission to be executed because of UAC. Do you have UAC disabled on your system?

I think UAC is at the minimal setting. I’d suggest contacting Avid support.

My UAC is at the default setting and my Eucon starts automatically with no issues.

J-S-Q - and it does not ask for permission ?

It starts for me but I have to relax the firewire wall as making an exception for it still causes issues otherwise.

You can force any program to start on login by setting it up in Task Scheduler. Mine starts by itself though. Do you have the latest version of EuControl and up to date firmware?

No, it just loads when I boot up my machine, as expected. I don’t recall having any issues at all -just downloaded/installed Eucontrol software and it has always worked throughout the various version updates so I guess you have something going on that is specific to your setup.

Hi all, yes I do have the latest EuControl Version and the firmware of all 3 devices is up to date.
So it must have to do with my win 10 pro and/or my total computer configuration.

Thx for your feedback!


When you install eucon it abound automatically put a shortcut to the exe (on PC) into the start up folder, if you browse to the Eucon folder it’s installed to, look in there, if the eucon app icon is in there run it, if it works and goes to your task bar then you know it’s working ok. You could just simple copy that app icon manually to the correct start up folder on your system.

Hope it helps