EuControl 2.7 released

For all of you who are using Avid /Euphonix Controllers, I just saw on the Avid Forums that EuControl 2.7 has been released.

The docs included in the installer are still from Version 2.6, so there probably isn’t much new stuff included. Below I quote the 2.7 change log from the Avid Forum.

regards, Mikael

EuControl is an application that runs Artist Control, Artist Mix, Artist Transport, and Artist Color media controllers and communicates with your software applications. This package installs EuControl and other necessary software. EuControl supports one Artist Control, one Artist Transport, one Artist Color, and up to four Artist Mixes.

What’s New
Provides support for Mac OS 10.8
Provides support for Windows 8
Support for Apple Mac Book Pro hardware with HiDPI Retina displays.
Note: Studio Monitor Express is not supported on Mountain Lion and is therefore not part of this release.

Bug Fixes
Mackie Control and HUI now work with Mac OS 10.7 and 10.8
“Bank to Selected” now behaves more predictably based on user request
EUCON System Preferences are now stored correctly on Mac OS 10.7 and 10.8
Improved stability with Pro Tools 10.3 (we recommend Pro Tools 10.3.3 for the best results)
Fixed an issue with USB mouse connection when device was disconnected causing loss of mouse control. This also affects KVM support which now functions correctly.

Hi (correction)

Just noticed that and after the download I just installed it.

I was really hoping some strange behaviour, which occur since CB7, shall be solved.
But…still no zooming in the edit windows, some short-cuts like “Back” not working (–>> other short-cut, this is now working, sorry), etc.

Seems to be a CB7 adapter issue. Have to investigate further, if there was a specific change in short-cuts from CB 6.07 (working) to CB7 (no more working)


omg euphonix was causing my mouse to disconnect all along! I was worried my motherboard USB ports were going bad…

TBH - EUCON Avid mc control and mc mix are connected by ethernet and not by USB - you must have another bug somewhere :wink: