Event is being recorded, but no sound!

Due to performance issues i had to reset my computer. I have re-installed cubase and also downloaded the Ur22 Driver, which i didnt have to update to mk2 driver. So i think regarding that i didnt do any mistakes.
If i try recording something now, cubase will record an event, but it is just a flat line, no sound at all. I rarely had that situation before, where i just had to switch the microfone on and off on my device and it would fix it. But as i said, that was very rare.
Now all i get when recording is a flat line. When i turn up the volume of the microfone on the device i can hear through my headphones, that it has been increased. but when i try to record something, it is like i said just a flat line.

Please help…^^

Omen 17ann0x
Windows 10 home x64
Steinberg UR22 MKII
Rode NT1a
tried out different cables, its not the issue…

Usually, this kind of issue is a routing one and/or a conflict between Cubase and the Windows audio management. So, could you post screenshots of the panels after having used the following commands ?

  • Studio>Studio Setup>Audio System (and its subpanel)
  • Studio>Audio Connections>Inputs
  • Studio>Audio Connections>Outputs

Hello, thank you for your fast answer!
I did the screenshots but i am not allowed to upload it…
I also cannot post a link^^
so what do we do?

here, i put an 8 inbetween. ^^


As far as I can see, you are using Input 1. Is your mix connected to the Input 1, please?

I can see valid signal at Audio track 1. How did yogurt this one? Could you attach a screenshot with the “flat” line?

What is the source? Do you use mic or Hi-Z or Line input? Did you set the Gain on the Audio Device correctly, please?


Got them, thanks.

So, the first thing I would do is to change the Inputs configuration to something like this :

[Bus name]             [Speakers]              [Audio Device]                  [Device Port]
Mono In 1                 Mono                 Yamaha Steinberg ASIO USB
                                                                               UR22MkII Input 1
Mono In 2                 Mono                 Yamaha Steinberg ASIO USB
                                                                               UR22MkII Input 2

Why so ? Because the UR22MkII have two independent mono inputs, one of them having a Hi-Z switch. From my experience, in the Audio Connections panels, the busses defined must be as much as possible the reflect of what our audio interface is capable of and nothing more. But yes, an alternative can be to also define an added stereo one, but either the stereo OR the both mono inputs should be connected to the driver at a given time. Overall, I’m wondering how you’ve been able to activate twice the first input : I’m absolutely not allowed to do this on my system, and for a good reason. In your case, there isn’t a stereo AND a mono hardware inputs, just two mono ones.

Concerning the stereo ones, you can let them as so, as they are obviously made to work together. I’m wondering about the lack of a headphones output bus, though : here, I have a dedicated one. So, does your unit allows the use of headphones and monitors at the same time, despite the lack of it ?

Beside this, I would deactivate the ASIO Guard (brings only hassles, IMO) and I’m wondering why the latency values are so high with the ASIO driver. They are more or less equivalent to 512 samples, values frequently used at a mixing stage, when many inserts are involved, not at a tracking one.

Once all these checked, be sure that Input Routing selector in the track inspector is set to either one or the other mono input.


Hello, thanks for another 2 fast answers!

First of all to answer Martin:
Yes, it is. I just took a picture without having it all set up. I did this one with the setup.
I always connect the audio tracks to the mono bus if thats what you mean. I have taken the requestet screenshot. I don’t know what you mean with the valid signal.

I usually use the left one, input 1 it is called. I have never looked into what it is though. I have turned the gain up more than i would usually do.

Then to answer cubic: Yes, all i have to do is set the output to stereo out and it will send L+r signal to my headphones without an extra bus. What do you mean by input routing selector?

A few more maybe interesting things:
I have found an old disc with the software, uninstalled the driver, installed the old software. If i want to switch to Steinberg usb Asio driver now, it tells me, that it is way over the capibility of my cpu (which is kind of funny since i have been using this software and driver for 2-3 years on this computer).

Also before i reset my pc, i could just use a regular usb headset with the generic low latency asio driver and set up busses and then record an audio with it. This doesn’t work anymore, too. It is the same flat line when i try to record something.

And last of all, when i look at my Steinberg Audio-Device while having the mic on, the Peak-led doesnt blink anymore. It did frequently when recording sounds if i remember correctly. So maybe my whole device is broken. I just wonder why it would be both entrances at once. Also my memory could be pranking me. So this probably is not the issue, just wanted to mention it.

I sadly dont really know anything about this software even tho i have been using it for so long. So i hope i did what you asked for.

Best regards


By the “valid signal”, I mean the Audio event on the track 1 ([FREE playboi…]). Did you import this audio file to the project?

Can you hear this signal?

It’s clear, the signal doesn’t come to Cubase.

Could you try to connect your source (what is it? Is it a microphone or a guitar, or…?) to the 2nd Input and set the Input to Mono 2 in Cubase? Can you hear/see the signal comes to Cubase now?

Try to Normalise the flat audio signal. Be careful with listening then, but… Can you hear something useful (your signal), or is it just a noise?

OK. I think that there is a routing conflict : do you have another audio device which could have been activated, since the computer “reset” ? Check if you haven’t two actual audio devices installed : the UR22 and an eventual audio chip on your laptop motherboard (something to check both in its BIOS and in the Windows settings). Deactivate everything (Windows “sounds” included) that isn’t related to the UR22 and try to record again with the already installed Yamaha Steinberg USB ASIO driver and one of the two mono inputs I was talking about previously.

Beside this, the Input Routing selector is this one (or its equivalent in the MixConsole) :


It is just an MP3 i inported into the DAW, it automatically sets the audio track and i can hear it.
I tried out both inputs, with the same result!
also i just hear nothing, when trying to listen to the “recorded” track.
What do you mean normalize?


Could you try to set No ASIO and then back your ASIO Driver in the Studio Setup > Audio System, please? Double check the Audio Connections after.