Events and Regions Deleted When Zooming [Solved -turn off..]

4 or 5 time an hour when zooming in and out with an event or region selected it Cubase and Nuendo will delete the even from the project window.

I of course can make a macro and deselect everything before zooming but I really don’t want to loose my selection 90% of the time.

This has bothered me for a long time but I usually just keep an eye on it and notice it when it happens and undo. Is there some particular reason this happens and has anyone else had this happen to them. It does it on any Mac system I use both Cubase and Nuendo and has persisted through the versions as long as I can remember at least back to version 5 but I think even back to version 1 this would happen.

Update: solved - turn off TextExpander auto capitalize preference under options


I’ve never had that problem, but I just wanted to suggest that you post a bit more detail, e.g. the steps you’re taking take when it happens, key presses, mouse presses etc. that you’re using. Then we can check out whether it happens on our systems, see if its repeatable.

Sometimes I have an issue where I use key commands and Cubase doesn’t notice that I’ve pressed modifier buttons (e.g. the shift key) and does something that I don’t expect, could that be it for you? I find this happens in big projects where the operation has become a bit sluggish.


Thanks a bunch Mike for the reply. I actually tried my darnest to make it happen by selecting random audio events and using g and h (zoom in and out). I have never been able to cause repeatable steps. The object selection tool is what is used to have the audio events selected (I really actually can’t say I can recall it happening when a MIDI region is selected). I do notice that it happens more often when I am on the selection tool and just finish recording audio and the event is naturally selected when I stop recording and then zoom in or out that it is deleted. No modifiers with G or H even deletes them I just tried every combination I could come up with and nothing deleted the audio event.

Could it be that you have a dodgy keyboard?

Spurious problems like this are the worst to tack down!! I’ve been on this forum (and the previous incarnation) for years and I’ve never heard anyone mention randomly disappearing/deleting events, but maybe someone else will chime in here???


Thanks a bunch for your reply Mike it has really helped me at dig deep and try to figure this one out. I have absolutely figured out what has been causing this after a lot of trial and error and Divine intervention. I just noticed that when I would open the key commands and press two letters where you type in commands that it would quickly flash delete and end with command+v. I used an animated gif app (LICEcap) and then opened in Apple Preview to see the command that was being executed and delete was one of them!

TextExpander’s preference “Capitalize new sentences” was the culprit. When I would press return (TextExpander thinks it is a new sentence) to open the editor and then close it with with return and press zoom in and then zoom out which are two commands that I do often that don’t require a modifier it would delete the selected event. Crazy thing is any two single keys would do that so I would be getting things deleted without even knowing it, which explains some of the frustration I have had with events gone missing!

I owe you big time for your help, you at least let me know you have never experienced it nor seen anyone else have this problem so I could look further into my setup. Hopefully this helps anyone else using TextExpander and Cubase or Nuendo. If you are beware!!

I just now exclude Cubase as one of the apps that this preference runs in, I might even just turn the feature off entirely to be safe. So glad to have that problem behind me, thanks again!

Text Expander Key Commands.gif

Hehey, that’s an unusual one for sure, no wonder no-one replied… Very glad you’ve sorted it :slight_smile:

May I suggest that you edit your post title and add [Solved - turn off TextExpander] or something like that, so as to help anyone else in the same situation.


That’s a great idea, thanks and happy new year!