Every time I record audio to a track it is delayed by an inconsistent amount

Hi everyone, first time poster.

Any help much appreciated.

I’m running Cubase LE AI Elements 8 64 bit.

Laptop ASUS N56V

Intel Core i7 - 3610QM CPU @ 2.30 GHz
8.0 GB RAM
NVIDIA GeForce GT 630M
NVIDIA High Definition Audio
Realtek High Definition Audio

Input is either guitar direct to/built in stereo microphones of ZOOM H4n to USB 3.0

ZOOM H series high performance ASIO driver version

Input latency is 5.011 ms
Output latency 12.925 ms
ASIO Guard altency 20.045 ms
sample rate 44.1 KHz

The variance in the latency of the recording is ridiculous. Sometimes its a few ms, other times it’s seconds.

So my workaround solution is record audio to track, then once I’ve played the part, I activate the metronome click, let it play and record 4 beats of click to the track, then stop the recording. I can then pull it back in to time manually by aligning the recorded clicks to the beat.
But surely, there must be an easier way.

It appears that the latency is related to how much processing the CPU is doing, eg, if I have multiple VST instruments running then the recorded track will be delayed by a larger amount.
Is my hardware not adequate for what I am trying to do?
Is there a way to ensure that an audio track is recorded in to its “true” position in time, or is there always a variance? And if so, why is it not the 5.011 ms of the input latency?

Is there a way, with the setup that I have to record audio without this variable and significant delay that requires rectification every time?

If I can provide any more information to assist please let me know, thanks for reading.

Confusedly yours, Luke

Try disabling your wi-fi. Not just disconnecting from wi-fi but completely disabling the adapter in device manager.

Thanks, I’ll give this a try and get back to you. How does that cause the issue?

Mmm the problem is still persisting. Has anybody else had this issue?

Try ASIO4all driver to rule out a Zoom audio driver problem.

Sorry to say these things are often not a simple fix but a systematic fault finding exercise that only you can do. Laptops are particularly prone for some reason…though often due to the wi-fi adapter you already tried disabling. Well assuming you did try it…as you didn’t actually say you had?

Stuff like disabling all the other audio devices except for the zoom…making sure nothing else is running in background. Disabling AV, checking all power management is set to full power. Have you done the typical Windows tweaks for audio?

I might not be understanding the issue correctly but, is this something that the “track delay” function would fix? I use it quite often on instrument tracks to get them back in time sync with my audio tracks. I actually have its use saved in some of my user templates.

The function is found in the track inspector and it let’s you adjust track timing +/-.

Regards. :sunglasses:

Thanks all for the responses. The track delay function would work if the amount the recorded part is delayed by was constant, but it can vary between successive recordings by up to several hundred milliseconds.
Even a second recordings taken immediately after the first can have a different latency it seems. I wish that I could utilize this feature as it would make life easier. Do you have the track delay set at your exact input latency?

I did try to disable the wireless adaptor, without change unfortunately.

What are the typical windows tweaks for audio exactly? I’ve cleaned the hard drive, defragged, have only cubase running during recording, but still the same.

It does seem to be worse when the are more vst instruments running. But what I don’t understand is why doesn’t cubase detect the time it will take to process everything and then pull the recorded track forward by this amount? It’s not like I need to monitor the incoming signal.

No it’s not. It might vary slightly from project to project but not for different tracks or different recordings in a project. I actually have it the delay setting already setup in some of my templates. I needed to do this in projects created after Cubase version 7.5.

For my system I don’t use the track delay function on audio tracks. Typically I would be using it on certain instrument tracks that always seem to be recorded late when compared to the audio tracks. My audio tracks are always recorded right on time. This confused me at first as I always was hearing my audio as early. But, it turns out some VST instruments are recorded late.

Good luck :wink:

Regards :sunglasses:

Cubase knows the reported latency of your audio driver and it knows any latency added by plugins and it corrects for that pretty well in most cases.
What you have is some kind of buggy driver/incompatibility issue.

Did you try ASIO4all as I suggested previously?