Evil Latency Issues w/ Cubase ai7 & Win 7

Good day to all.

I return to the forum with latency issues.

I did a test using every bit rate option. From 64 to 2048 bits. The lower ones around 64 bits were worse, than say the 1024 and 2048. But even then the later on 2048 still had pops and glitches, along with the audio dropping out ever so often.

What should one do?

I’m running Win 7, cubase ai7, and UR22 interface.

-Alexander Lee

Did you turn off your antivirus?

Antivirus and other background running programs can wreak havoc with DAWs.

Wi-Fi enabled?

Run this tool, it doesn’t require any software installation …


Yes my antivirus and other background settings are off and disabled.


Thanks for Latency checking tool link. It’s reminding me how not close i am to defeating my issues, but It’s giving me real time solutions. Thanks

Has anyone come up with a solution or does this UR22 get returned. I need a quick and easy solution for creating some demos and have don’t have time to screw around with this.

I know man, tell me about it. But I have an answer.


Once more is added. I’ll know for sure.


I have found a solution. After spending a full day with two laptops using Windows 7 and not Cubase, the latency problem did not go away. However the the UR22 is going away. Solution: return the unit. Result: problem resolved.

Hey Steinberg, some of us do not want to spend hours configuring hardware and software. We would prefer to compose and record music. If this is the best you can do to stick with software. I know Windows sucks and Apple base platforms are superior for intensive processing, however there are millions of Win/Intel/AMD machines out there and if you are not able to easily elimintate something as straightforward as latency then you probably want to spend more time in R&D.

sleepinthecar and zontar999:

Just curious-- do you guys know about
the “Constrain Delay Compensation” button on the top left of the toolbar :question:
I use it once in a while for recording then turn it off for mix down.

Also have you guys lowered your Buffer size to the Lowest setting
in the Cubase ai7 control panel for recording. Keep your mix control
all the way to the right–set for Daw–not input.
Then increase your buffer size for mixdown :question:

I Almost always use this trick when I record
with the mix knob always turned to the
right on DAW :wink:

Hope this helps :slight_smile:

Jack :smiley: :smiley: