EWQL PLAY: Error Creating Plugin Window - HELP!

Hey everyone,

I just bought Cubase 5 (if C6 comes out anytime soon, I’m gonna be mad), and the first thing I tried to do was load up EastWest’s PLAY library, having also recently purchased their Complete Composer’s Collection. Of course, it didn’t work.

Specifically, it wouldn’t load the plugin window, so I couldn’t do anything within the plugin.

Here is the message I sent to Steinberg support, but they haven’t replied. I’m pretty frustrated because I need to get music done (I’m a film composer) for clients across the country. Any help would be extremely appreciated!

While attempting to open EWQL PLAY vst64 on an instrument track in Cubase 5.5.2, I receive this error message, quoted verbatim:

“PLAY: Error Creating Plugin Window:
Widgets must be created in the GUI thread. Please contact Tech Support!”

After clicking “OK” (the only option), the message disappears and I am left with a blank, white plugin screen - and no PLAY.

Since the first time I attempted to load the VSTi, this error message appeared. I was running the 32-bit version of this plug-in (as well as the both 32 and 64-bit stand-alone versions) without any problems on Cubase AI4, and am at a loss to explain why it would fail so completely on a newer DAW. I tried it on an older version of Cubase 5, to no avail - I received the same message. Of course, I have restarted my computer multiple times, among other standard Win7 fixing attempts, and nothing has worked.

My system specs are as follows (everything else works great, and the stand-alone version of PLAYx64.dll works like a charm):

Windows 7 64bit
Intel Quad-Core i5 @ 2.67ghz
TASCAM external audio mixer + VIA HD internal Sound Driver
Yamaha Motif XS
ATI 5770 1GB
ASUS Pro Mobo
SATA 6gb/s (500 GB + 1TB)

As I said, this all worked great in Cubase AI4 and also works in Sony Acid MS7…it’s just Cubase 5, the leading DAW in the world, that my $1000 VSTi doesn’t work on. As you might be able to tell, I’m not impressed.

If anyone can help me, I’d be very grateful!


Hey again,

Disregard my earlier message…the plugin now works.

Turns out it was a matter of Cubase 5 attempting to load the 32-bit version of PLAY. Once the 64-bit version was used (after some tweaking/shifting of directories), the engine loaded well!

Sorry for the inconvenience, and hope my experience helps others with the same problem!