Exported Files Timing is Off without Constrain Delay Compensation

Hello,

I’m running Cubase 10 now and I’m having some issues with the timing on exported files. When I record tracks, I use “Constrain Delay Compensation” so I hear everything in perfect sync. That’s great, but when I want to take off Constrain Delay Compensation and export a track, for example a bass track with all the effects on it, that track comes out with the timing slightly off, causing it to not line up with the other tracks. If I export the dry bass file with no effects and using the Constrain Delay Compensation button, the timing is fine. This doesn’t make sense, as an export should be able to correct any timing issues, as apposed to trying to monitor with lots of effects running. It also happens when I export a full mix. My in-point is right before the hit of a kick drum, and when I export with full effects, that first kick gets cut off unless I move the in-point ahead to compensate.

Is there some export setting that allows me to export with all the effects, and that doesn’t affect the timing of the exported file?

Thanks.

Do you just turn it off for exporting, not for mixing?

CDP is made for decreasing latency while recording. It disables plugins that cause a lot of latency and is meant temporary. Whenever recording is done, turn it off. When you mix with it on, then turn it off just for exporting, it might shift your tracks by the exact values of the plugin latencies/mess up your timing.

Never experienced myself as I usually monitor directly from the soundcard. So this is just a theory maybe worth checking.

I do understand the proper way to use the Constrain Delay Compensation function. The problem is that when I am done tracking and want to export a mix or a single track with effects, I turn off Constrain Delay Compensation then export, and the resulting files are off a few samples causing a sync issue if I want to put those tracks into a project. I also tried exporting in real-time, but the same problem persists.

There must be some setting that stops this.

You may have a plugin that is incorrectly reporting it’s latency.

I have recently assed the Weiss MM-1 Limiter. It cut off the first beat where the old Stealth Limiter did not, but my friend tested it in Logic and that did not happen. Oy I hate this stuff…

Yes, I have experienced this and would guess it is the most likely cause. For example one of the Waves multiband plugins (L3 Multimaximiser I think?) will delay the timing of your audio.

Hi to everyone. This audio dropout/ latency issue in cubase10.5 pro really disturbing my creativity & work flow. The constrain delay compensation is a cool future to help you deal with latency issue when recording, I really love the magic it play on my timing issue. But can I leave it on & export my my mix? I really want to get that perfect timing audio mixdown, also when mixing too. So can I keep it on all through the process of my mix?