Exporting audio results in trumpet sounds for all parts


I exported an mp3 of a piece, but all the parts played back as trumpet sounds - even the percussion! I am able to export a WAV file normally, but the mp3 export won’t work. I am running Dorico 2.2 and NotePerformer 3. Is my file corrupted or something?


Joshua Kriegl

Are you on Mac or Win? On Mac we had cases where the caching of iTunes played a trick, i.e. playing back an old version of a file that got already updated in the meantime. Other than that I have no explanation because the mp3-encoder can’t change a sound to trumpet.
Would you mind sharing your project file here (or send me via private mail)? Thanks

Also try reapplying the NotePerformer playback template. Only brass in NP indicates that the instrument routing/config has failed…

Maybe you got hacked by a trumpet player. :grinning:


I am on Mac (OS Mojave).
Here is the file.
B&L - Mvt. 1 (Complete).dorico (1.5 MB)
I tried doing as @fratveno suggested and reapplied the NotePerformer playback template via play<playback templates to no avail.

I don’t think a trumpet player would appreciate playing the piccolo part :wink: :joy:

FWIW, mp3 export of your file worked fine for me in 3.5. Resultant file is 25.6 MB so too big to upload to the forum without further downsampling.

Same here. I load the project, export to mp3 and it sounds all correct.

Try following, do a new export and then in Finder make a copy of the file with a different name. Then open that copy in iTunes or whatever player you use. Still everything just trumpets?

I opened your project in Dorico 2.2.20 and it loads with the NP instances unconfigured. If you export audio at this stage you get the problem.

In 2.2 you need to start playback from the beginning of the file, just a few seconds will suffice, and then the NP instances populate properly. In Dorico version 3.5.12 the audio export routine will populate the NP instances automatically, and hence the problem is not present there. I don’t know which version of NP you are using, but I would update to the latest, it’s free…

1 Like


Thank you so much for your help! I have NotePerformer 3, but I finally got it to work by adding an empty measure at the beginning. Just out of curiosity, how are you able to check if the NotePerformer instances have populated properly?

Click the little e-button to open the NotePerformer window. If it shows the mixer it loaded fine.