Exporting MIDI

I’ve always wanted to know why exporting a MIDI file in Cubase results in all the notes being 2 ticks shorter than what they were before exporting. For example; I export a MIDI part with exact 16th note lengths, which is 120 ticks. When I import the MIDI file I just exported, the notes are 118 ticks in length. It’s more a question than a problem. Anyone know why?

Have you changed either your internal or export resolution?

I’d never even noticed that! :slight_smile:
Anyways…
The Export takes into consideration the parameter in Preferences>MIDI>“Length Adjustment”.

Vic,

You make a good point. But isn’t that setting only for notes that end the same time as the next same note starts? For example; C3 -> C3, but C3 -> E3 wouldn’t be affected. This is happening for every note, even of different pitch. I would upload a screen shot except I’m not at home at the moment. Is anyone else experiencing the same thing?

(editing… had to go double-check :wink: )…

No, it is global. I think you are referring to the “Legato Overlap” setting, but there again, it isn’t limited to consecutive notes of the same pitch.

If that’s the case then that would make sense because my Length Adjustment is set to -2 ticks. When I get home I’m going to change that setting and see if it makes a difference. Just more curious than anything becaus I’ve always wanted to know why it insists on chopping off 2 ticks of the note lengths. Thanks for your help.

Well you were right Vic. I set the Length Adjustment to 0 ticks and it exported without shortening any notes. But if you look in the manual, it says:

Length Adjustment
Adjusts the length of notes so that there is always a short time between the end of one note and the start of another (of the same pitch and on the same MIDI channel). You set the time in ticks. By default there are 120 ticks per 1/16 note, but you can adjust this with the MIDI Display Resolution setting on the same page.

It is only supposed to be for consecutive notes of the same pitch, so I’m thinking Cubase isn’t exporting to MIDI correctly. Anyway, now I know why. Thanks again!

In that case, if the behavior is supposed to be as described in the manual, then it isn’t working correctly :wink:.